File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes Error when opening Visual Age Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Error when opening Visual Age" Watch "Error when opening Visual Age" New topic
Author

Error when opening Visual Age

Jennifer Sohl
Ranch Hand

Joined: Feb 28, 2001
Posts: 455
Hi. I am using Visual Age 3.5 and I keep getting an error message when trying to open it:
IDE.EXE - Application Error
The instruction at "0x045b2080" referenced memory at "0x045b2080.
The memory could not be "read".
I did figure out that it has something to do with the ide.icx (workspace file). If I replace it with a backup copy that I have, I can get into VAJ, but this is a pain seeing as how I have to add everything back to my workspace from the repository.
But, as soon as I exit Visual Age and try to get back into it, I get the error message again.
I would be forever grateful is someone could give me any sort
of clue on how to fix this problem. (I have tried reinstalling, still get the message.) I am running Windows 2K.
Thanks in advance!
Fred Abbot
Ranch Hand

Joined: Jun 01, 2000
Posts: 300
get FixPack2 that willsolve your problem
Jennifer Sohl
Ranch Hand

Joined: Feb 28, 2001
Posts: 455
We have applied Patch2 and still get the error message. Any other suggestions?
Just a note: Tried using another machine and totally recreating
my application. The minute I got out of it and back into it, the error message now appears on the other machine. Could it possibly be something in the application causing this??
Thanks!
Kumarasun Nadar
Greenhorn

Joined: Apr 25, 2001
Posts: 2
If you have installed Mccafe antivirus uninstall it, try open VAJ again. This may solve your problem


Sun Certified Java Programmer( 94 %)
D Clough
Greenhorn

Joined: Dec 11, 2002
Posts: 1
I'm having the same issue. Any answers would be greatly appreciated! I got this error just after my test application ran into a deadlock on a DELETE statement issued to a remote DB2 database. It was impossible to kill the application within visualAge - even after recycling the remote server and client connection . So I exited out of VisualAge, which I was able to do gracefully, and re-booted my machine. I haven't been able to get into VisualAge since.
[ December 11, 2002: Message edited by: D Clough ]
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
You have a dead workspace file. This happens fairly commonly in VAJ. This is why you should keep backups of your workspace often. There is no solution other than to go back to the default ide.icx and rebuild it from the repository -- at least everything is in the repository and you have not lost any code -- just some time.
Kyle


Kyle Brown, Author of Persistence in the Enterprise and Enterprise Java Programming with IBM Websphere, 2nd Edition
See my homepage at http://www.kyle-brown.com/ for other WebSphere information.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5827
    
    7

Analia Ff,
Your post was moved to a new topic.


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error when opening Visual Age