aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Having Trouble with Ormondo UML Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Having Trouble with Ormondo UML" Watch "Having Trouble with Ormondo UML" New topic
Author

Having Trouble with Ormondo UML

Jim Rock
Ranch Hand

Joined: Mar 20, 2001
Posts: 39
Can't get a class diagram file built.
I use the wizard, fill in the info click "finish" and it just hangs. I am going to try reloading everything - unless someone has a "quick fix".
I already reset defaults and made sure EMF / GEF were there.
Stelian Iancu
Greenhorn

Joined: Feb 20, 2002
Posts: 21
What version of Eclipse are you using? I've got the same behavior, but I was using a version from the 3.0 stream. The Omondo UML plug-in works ok with Eclipse 2.1.
AFAICS, the diagram is made even though the plug-in hangs, so try to click Cancel and see if it's there.


--<br />Linux registered user 287835<br /> <br />Be different. Think.
Tarun Ramakrishna Elankath
Greenhorn

Joined: Mar 27, 2002
Posts: 27
Have you chosen the new EMF diagram wizard or the UML diagram wizard ?
Jim Rock
Ranch Hand

Joined: Mar 20, 2001
Posts: 39
I am using Eclipse 2.1.1 on Win 98. EMF works fine. With Ormondo UML class diagram, I get the splash page and then a wizard that collects file name info, but when I click "finish" nothing happens.
Robert McGovern
Author
Greenhorn

Joined: Jul 08, 2003
Posts: 8
Originally posted by Jim Rock:
I am using Eclipse 2.1.1 on Win 98. EMF works fine. With Ormondo UML class diagram, I get the splash page and then a wizard that collects file name info, but when I click "finish" nothing happens.

It __may__ be a case that Omondo isn't compatible with Eclipse 2.1.1 but I haven't seen anything to suggest that yet.


Co-author of <a href="http://www.manning.com/gallardo" target="_blank" rel="nofollow">Eclipse In Action</a>
Jim Rock
Ranch Hand

Joined: Mar 20, 2001
Posts: 39
I checked the error log and running the class diagram wizard is throwing the following error:
java.lang.NoClassDefFoundError
I've reported it to support@omondo.com. I'll let you know if they respond.
Jim Rock
Ranch Hand

Joined: Mar 20, 2001
Posts: 39
I got the Ormondo UML plugin working by changing to a stable version of the Eclipse/EMF plugin
David Yutzy
tumbleweed and gunslinger
Ranch Hand

Joined: Jun 29, 2001
Posts: 192
I couldn't stand that plugin...
Any plugin that forces me to code "their way or no way" is useless.
BTW, how can you generate a diagram without building a diagram using their plugin? Duh, you can't. Unless you build a class diagram using their tool, you cannot take existing code and create the diagrams from scratch.
Jim Rock
Ranch Hand

Joined: Mar 20, 2001
Posts: 39
I've right-clicked on an existing Java package in my project and select UML Class Diagram (Ormondo Plugin). It creates a UML Class Diagram of all my classes in that package... although it doesn't show the associations.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Having Trouble with Ormondo UML
 
Similar Threads
Cant use object from another class
Text box value is not being completely filled with request attribute
Posting to bump up my count...
The x900 effect ?
WA #1.....word association