This week's book giveaway is in the Jobs Discussion forum.
We're giving away four copies of Soft Skills: The software developer's life manual and have John Sonmez on-line!
See this thread for details.
Win a copy of Soft Skills: The software developer's life manual this week in the Jobs Discussion forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

problem deployingTomcat project on Eclipse

 
rick collette
Ranch Hand
Posts: 208
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, Guys:
I really need you guys help on this. I installed Sysdeo Tomcat plugin on Eclipse. I have tried to deploy a Tomcat project on Eclipse (using a servlet),
but failed many many times. I do not know what is wrong with my setup. If anyone knows how to successfully deploy a tomcat project, please teach me how to do it. Its really a pain in the butt.
Thanks a bunch!
Rick
 
Gavin Bong
Ranch Hand
Posts: 56
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What I've done to be able to debug servlets is to configure the classloader to load classes from my workspace/bin in addition to WEB-INF/classes or WEB-INF/lib. That way, I do not need to deploy anything.
If you meant deploying the classes to the tomcat_home; just use ant and the copy task.
Gavin
 
Chad McGowan
Ranch Hand
Posts: 265
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What type of error are you getting?
 
rick collette
Ranch Hand
Posts: 208
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry for giving late reply, I have been really busy.
Hi, Chad:
Since I used tomcat-plugin, I have not been able to even start up tomcat normally, it always gives me
ClassNotFoundError in URLClassLoader class. I am not why I am getting this. Thanks.
rick

Originally posted by Chad McGowan:
What type of error are you getting?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic