Meaningless Drivel is fun!*
The moose likes IDEs, Version Control and other tools and the fly likes WSAD JNDI Explorer problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "WSAD JNDI Explorer problem" Watch "WSAD JNDI Explorer problem" New topic
Author

WSAD JNDI Explorer problem

Graham VMead
Ranch Hand

Joined: Sep 22, 2003
Posts: 154
Hi
I've been trying to check out using JNDI to locate a remote object and was going thru an IBM article which got you to start a transient name server
via tnameserv.exe in the java bin directory of WSAD listening on port 900
with this code
InitialContext ic = new InitialContext();
ic.createSubcontext("Test2");
passing in JVM parameters of
-Djava.naming.factory.initial=com.sun.jndi.cosnaming.CNCtxFactory -Djava.naming.provider.url=iiop://localhost:900
This bit worked fine so I thought I'd try and look at the JNDI tree via JNDI Explorer in WSAD setting the JNDI properties to those above.
This bit fails miserably and just says "IWAD0404E Error resolving context" is this possible and if so what am I doing wrong
TIA Graham
Gaurav Jain
Ranch Hand

Joined: Mar 11, 2004
Posts: 108
right click on the EJB name and click on properties.
You will find the jndi name over there.
Try looking up through that jndi name.
Graham VMead
Ranch Hand

Joined: Sep 22, 2003
Posts: 154
Thanks for the reply but my main problem is the fact that I've tried to set the JNDI properties of the explorer to -
Context factory =com.sun.jndi.cosnaming.CNCtxFactory and the
provider url to=iiop://localhost:900
so that I could view the JNDI bindings on the remote server via the JNDI explorer but I'm obviously doing something wrong because it can't find it.
Gaurav Jain
Ranch Hand

Joined: Mar 11, 2004
Posts: 108
provider URL is 2809 and not 900
Graham VMead
Ranch Hand

Joined: Sep 22, 2003
Posts: 154
The transient name server is listening on 900 not 2809. Gave up on JNDI Explorer and downloaded an eclipse plugin, this works fine when pointing at port 900
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WSAD JNDI Explorer problem