This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse Startup Problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse Startup Problem" Watch "Eclipse Startup Problem" New topic
Author

Eclipse Startup Problem

Steve Daly
Greenhorn

Joined: Nov 04, 2003
Posts: 4
For some reason I can no longer start Eclipse M8. Everything worked last week until I had to uninstall/reinstall JDK 1.4.2_04 to a new location on my drive. I get a JVM Exit Code 3 and the following log information:
!SESSION May 10, 2004 09:38:26.266 ---------------------------------------------
java.version=1.4.2
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
!ENTRY org.eclipse.osgi May 10, 2004 09:38:26.296
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Unable to locate application extension: org.eclipse.ui.ide.workbench
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:263)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:239)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:117)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.basicRun(Main.java:267)
at org.eclipse.core.launcher.Main.run(Main.java:692)
at org.eclipse.core.launcher.Main.main(Main.java:676)
I have Google'd my way around the 'net and cannot get a lead. I reinstalled Eclipse to a new drive and I still get a dialog box with the error. I have tried to run from the command line (both with the launcher and the javaw.exe) with no luck.
HELP!
TIA,
Steve
Tim West
Ranch Hand

Joined: Mar 15, 2004
Posts: 539
Me and someone else discussed a different Eclipse startup problem a while back, but the "solution" (it was somewhat unsatisfactory, but it worked) we arrived at may work for you too. Read here.
Cheers,

--Tim
Steve Daly
Greenhorn

Joined: Nov 04, 2003
Posts: 4
Tim,
Thanks for the link, but it didn't help the problem.
I can get Eclipse running if I start it from the command line. I have to tell it the JVM to use along with the other "standard" options.
It's just wierd though. I cannot figure out where to change the startup options. I can't find a file that has the information or anything in the registry.
Tim West
Ranch Hand

Joined: Mar 15, 2004
Posts: 539
Hey Stephen,
Eclipse manages its own config in the <eclipsedir>/.config directory. I had a quick look but I don't think you're supposed to edit the files there by hand
Aside from creating a shortcut/batch file that passes appropriate options, I dunno what to do from here....Eclipse seems to be a bit like that. I don't know of anywhere you explicitly set the JVM etc. That said I don't pass any command line args explicitly, so maybe there are defaults that work in most situations.
Sorry I couldn't help more
--Tim
Dirk Schreckmann
Sheriff

Joined: Dec 10, 2001
Posts: 7023
Have you tried just installing a fresh copy of Eclipse?


[How To Ask Good Questions] [JavaRanch FAQ Wiki] [JavaRanch Radio]
qingwu wang
Ranch Hand

Joined: Feb 19, 2003
Posts: 147
u can install fresh eclipse system then copy directories in.


Thanks...qingwu<br />When I open my eyes,I see your pretty face.
Alex Ku
Ranch Hand

Joined: Jan 15, 2002
Posts: 47
I had the same problem. I just deleted every in the configuration folder except config.ini
I think by doing so, it just re-create all the setting.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse Startup Problem
 
Similar Threads
[eclipse + win98]: Does not open
Eclipse 3.0 Installation problems
Lomboz giving error in Eclipse.
Eclipse install problem
Running Eclipse 3.0 error...