wood burning stoves 2.0*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse + Web Tools, JSP doesn't find TLDs Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse + Web Tools, JSP doesn Watch "Eclipse + Web Tools, JSP doesn New topic
Author

Eclipse + Web Tools, JSP doesn't find TLDs

David Heffelfinger
author
Ranch Hand

Joined: Jul 08, 2004
Posts: 176
Hello,

I recently downloaded the Eclipse Web Tools Project Plugin.
I'm having problems with the JSP editor not recognizing custom tags.

It looks like it can't find the tld files.

I've looked around for some preference telling it where to find
TLDs, but haven't been able to find anything.

Does anyone know how to fix this?

Thanks,
David
[ October 17, 2007: Message edited by: David Heffelfinger ]

Author, <a href="http://www.packtpub.com/java-ee5-development-with-netbeans-6" target="_blank" rel="nofollow">Java EE 5 Development with NetBeans 6</a>
Wayne Parrott
Greenhorn

Joined: Feb 04, 2004
Posts: 9
Hi Ray,

The IBM WTP contributions are super buggy and full of suprises. But in fairness they are only posted for WTP consideration. Presently you must place your TLD in the same folder as your JSP file for the editor to find it. Once you get past that problem be prepared to hit others.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse + Web Tools, JSP doesn't find TLDs
 
Similar Threads
Custom Tags in Jsp
Which editor for JSF?
java version CGIProxy?
Eclipse: Cannot find tag library descriptor
java version CGIProxy?