Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Eclipse3.0 Build all and build project not working

 
shailendra shewale
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all
I deleted the class files in my default eclipse output(build) folder.
When i restarted eclipse and clicked build all or build project,nothing happens.Even eclipse doesn't create class files after build all or build
project on build path provided.
Can somebody help please?
I guess Nira Shavitt had same problem,was she able to find a solution?


shailendra shewale
 
David Hibbs
Ranch Hand
Posts: 374
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I haven't used 3.0 much yet, but I've seen similar issues with earlier releases. Generally if you touch a file, it should rebuild it on a save unless you have auto-builds disabled. When you delete the .class file, it isn't aware of it. You can try a refresh operation, then touch a file (open it, space, delete, save) to see if it will pick up the change and rebuild the needed files.

The other option is to
1) disable builds on resource modification
2) Right Click a project and select Rebuild Project
 
shailendra shewale
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you David for showing interest in my problem.but it didint help. actually even if i disable auto-build and build manually after refresh and whatever u have suggested,it still does not create class files on build path.

I have to start from configuring a new java project in eclipse then it builds.
but this is not practical after every change that i make.

any comments?

thanking you
shailendra shewale
 
Fred Grott
Ranch Hand
Posts: 346
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hmm have you checked the ant preferences console yet?
 
Nira Shavitt
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,

yap, I had the same problem and I couldn't resolve it. I build an ant build file and used it whenever I wanted to build the project, but then Eclipse build all the files for every minor change. I couldn't get any explanation for this problem. sorry.

Nira Shavitt
 
Ilja Preuss
author
Sheriff
Posts: 14112
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by shailendra shewale:
Thank you David for showing interest in my problem.but it didint help. actually even if i disable auto-build and build manually after refresh and whatever u have suggested,it still does not create class files on build path.


Try "Project / Clean...".
 
shailendra shewale
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
oh,thank you so much Ilja,

Project->clean worked for a new build from scatch.

I got my problem solved.

Thanx everybody.

Shailendra shewale
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic