wood burning stoves 2.0*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse3.0  Build all and build project not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse3.0  Build all and build project not working" Watch "Eclipse3.0  Build all and build project not working" New topic
Author

Eclipse3.0 Build all and build project not working

shailendra shewale
Greenhorn

Joined: Jul 30, 2004
Posts: 10
Hi all
I deleted the class files in my default eclipse output(build) folder.
When i restarted eclipse and clicked build all or build project,nothing happens.Even eclipse doesn't create class files after build all or build
project on build path provided.
Can somebody help please?
I guess Nira Shavitt had same problem,was she able to find a solution?


shailendra shewale
David Hibbs
Ranch Hand

Joined: Dec 19, 2002
Posts: 374
I haven't used 3.0 much yet, but I've seen similar issues with earlier releases. Generally if you touch a file, it should rebuild it on a save unless you have auto-builds disabled. When you delete the .class file, it isn't aware of it. You can try a refresh operation, then touch a file (open it, space, delete, save) to see if it will pick up the change and rebuild the needed files.

The other option is to
1) disable builds on resource modification
2) Right Click a project and select Rebuild Project


"Write beautiful code; then profile that beautiful code and make little bits of it uglier but faster." --The JavaPerformanceTuning.com team, Newsletter 039.
shailendra shewale
Greenhorn

Joined: Jul 30, 2004
Posts: 10
Thank you David for showing interest in my problem.but it didint help. actually even if i disable auto-build and build manually after refresh and whatever u have suggested,it still does not create class files on build path.

I have to start from configuring a new java project in eclipse then it builds.
but this is not practical after every change that i make.

any comments?

thanking you
shailendra shewale
Fred Grott
Ranch Hand

Joined: Oct 05, 2002
Posts: 346
hmm have you checked the ant preferences console yet?


MobileBytes blog - Sharing Technology - My Programming Knols
Nira Shavitt
Greenhorn

Joined: Jul 26, 2004
Posts: 19
hi,

yap, I had the same problem and I couldn't resolve it. I build an ant build file and used it whenever I wanted to build the project, but then Eclipse build all the files for every minor change. I couldn't get any explanation for this problem. sorry.

Nira Shavitt
Ilja Preuss
author
Sheriff

Joined: Jul 11, 2001
Posts: 14112
Originally posted by shailendra shewale:
Thank you David for showing interest in my problem.but it didint help. actually even if i disable auto-build and build manually after refresh and whatever u have suggested,it still does not create class files on build path.


Try "Project / Clean...".


The soul is dyed the color of its thoughts. Think only on those things that are in line with your principles and can bear the light of day. The content of your character is your choice. Day by day, what you do is who you become. Your integrity is your destiny - it is the light that guides your way. - Heraclitus
shailendra shewale
Greenhorn

Joined: Jul 30, 2004
Posts: 10
oh,thank you so much Ilja,

Project->clean worked for a new build from scatch.

I got my problem solved.

Thanx everybody.

Shailendra shewale
 
GeeCON Prague 2014
 
subject: Eclipse3.0 Build all and build project not working