File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Upgrade to IDEA 4.5

 
Hussein Baghdadi
clojure forum advocate
Bartender
Posts: 3479
Clojure Mac Objective C
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all.
according to jetbrains :
(in case we have IDEA 4.0)
Simply download IntelliJ IDEA 4.5 and continue using your current license.
I have IDEA 4.0 , should I uninstall my IDEA 4.0 and install IDEA 4.5 ?
or just run the downloaded file (without uninstalling 4.0) ?
thanks.
 
Ernest Friedman-Hill
author and iconoclast
Marshal
Pie
Posts: 24204
34
Chrome Eclipse IDE Mac OS X
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You don't have to uninstall. I always backup my .IntellJIdea directory (where all the preferences and such are kept in your home directory) before doing an upgrade.

I actually backed off from 4.5 after installing it, because several of the plugins that are important to me hadn't been upgraded yet. I was glad I had the backup of the .IntelliJIdea directory. I should go and check and see if new plugins are ready yet.
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In my experience, it worked fine to just install 4.5 to a different directory, and input the licensing information during installation and first use of version 4.5. No need to uninstall 4.0.

So, if you'd like to keep 4.0 around just in case you don't like something about using 4.5, then my experience suggests to me that you're safe to do so.
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I always backup my .IntellJIdea directory (where all the preferences and such are kept in your home directory) before doing an upgrade.

I configured IDEA to use the installation directory, not the user's home directory. I am the only user of IDEA on my system.
 
Hussein Baghdadi
clojure forum advocate
Bartender
Posts: 3479
Clojure Mac Objective C
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry, but I have some questions please.
can I have two versions of intellij (4.0 and 4.5) installed in the same system (WinXP) ?
will they conflict with each other ?
I have intellij 4.0 installed in C:\IntelliJ-IDEA
so, install intellij 4.5 (lets say) in E:\IntelliJ dir ?
after installing intellij 4.5 and running it for the first time, will it ask me to enter the license or it will use intellij 4.0 license ?
I am really confused, thanks for help.
 
Mark Spritzler
ranger
Sheriff
Posts: 17276
6
IntelliJ IDE Mac Spring
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by John Todd:
Sorry, but I have some questions please.
can I have two versions of intellij (4.0 and 4.5) installed in the same system (WinXP) ?
will they conflict with each other ?
I have intellij 4.0 installed in C:\IntelliJ-IDEA
so, install intellij 4.5 (lets say) in E:\IntelliJ dir ?
after installing intellij 4.5 and running it for the first time, will it ask me to enter the license or it will use intellij 4.0 license ?
I am really confused, thanks for help.


No they will not conflict with each other. I have both on WinXP Pro at work here.

You still have to add/type your license to the new version.

Mark
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic