It's not a secret anymore!*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse Visual Editor , the design pane disappear Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse Visual Editor , the design pane disappear" Watch "Eclipse Visual Editor , the design pane disappear" New topic
Author

Eclipse Visual Editor , the design pane disappear

Edward Chen
Ranch Hand

Joined: Dec 23, 2003
Posts: 798
I am using Eclipse Visual Editor . after I new a visual class and loading small window, the design pane doesn't have anything, such as The JFrame window and its child JPanel. I can't change the JFrame setting. But the coding still is there.

Thanks
Denis McCarthy
Greenhorn

Joined: Oct 16, 2004
Posts: 4
I get the same problem with eclipse 3.0.1 EMF 2.0.1 GEF 3.0.1 and VE 1.0.

I create a simple layout but as soon as I edit the code and then run it the frame pops up but the Java Beans panel that shows the items gets cleared and the gui editor panel gets cleared as well. The code remains the same.

Restarting the editor doesn't help. It doesn't bring back the layout.
Does anyone know does it use tags to help it rebuild the code like some other gui layout tools or does it do it all by source...

(brings me back to the good old days of fighting visual crape 3 to develop swing apps)
Denis McCarthy
Greenhorn

Joined: Oct 16, 2004
Posts: 4
Remove the EMF examples plug-in from your Eclipse installation and it should work fine.

I found the answer from someone on the eclipse VE newsgroup...

If you need help removing it let me know
 
 
subject: Eclipse Visual Editor , the design pane disappear
 
Similar Threads
What are the IDE's people use for GUI building ?
Eclipse Visual Editor Help needed
Visual Design (Swing) editor in Eclipse - where?
Eclipse visual editor install and implimenting issue
cant reuse panel?