aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes WSAD 5.1.x --> JDK 1.5??? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "WSAD 5.1.x --> JDK 1.5???" Watch "WSAD 5.1.x --> JDK 1.5???" New topic
Author

WSAD 5.1.x --> JDK 1.5???

Thomas Mcfarrow
Ranch Hand

Joined: Jul 09, 2001
Posts: 137
Hello,

I tried to upgrade JDK 1.4 to 1.5 in WSAD 5.1.2 but it didn't work.

I could change the JRE to 1.5: Window -> Preferences ->Java ->installed JREs.

The problem is that I can't change the compiler to 1.5 from 1.4 to support the new constructs (generics, autoboxing, etc) and compile!!!

How do I upgrade the complier to 1.5 in WSAD 5.1.2?

Thanks in advance!
Paul Sturrock
Bartender

Joined: Apr 14, 2004
Posts: 10336

You can't. WSAD is very restrictive when it comes to the JDK versions it supports. This seems to be because it doesn't want to allow you to write code in a JDK newer than WebSphere itself supports (for example, WSAD 5.0 doesn't support anything higher than 1.3.1). Very, very annoying I know.

You might just want to use normal Eclipse, rather then the WSAD-flavoured version.


JavaRanch FAQ HowToAskQuestionsOnJavaRanch
Thomas Mcfarrow
Ranch Hand

Joined: Jul 09, 2001
Posts: 137
Thanks for the reply,

It is very very annoying... does anyone know a hack?

I guess I could download and install eclipse .
Bharat Ruparel
Ranch Hand

Joined: Jul 30, 2003
Posts: 493
Your solution can be as simple as upgrading to RAD6 from WSAD 5.1.2. RAD6 is based on Eclipse 3.x technology and therefore natively uses 1.4.x JRE.
Bharat


SCJP,SCJD,SCWCD,SCBCD,SCDJWS,SCEA
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 30309
    
150

RAD 6 currently uses 1.4. The version of Eclipse using 1.5 is still in beta, so no versions of WSAD have support yet.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
Ilja Preuss
author
Sheriff

Joined: Jul 11, 2001
Posts: 14112
Originally posted by Paul Sturrock:
You can't. WSAD is very restrictive when it comes to the JDK versions it supports. This seems to be because it doesn't want to allow you to write code in a JDK newer than WebSphere itself supports (for example, WSAD 5.0 doesn't support anything higher than 1.3.1). Very, very annoying I know.


A more legitimate reason might be that to support a newer JDK, the Eclipse compiler needs to be adapted, and that work was just finished in the 3.1 stream.


The soul is dyed the color of its thoughts. Think only on those things that are in line with your principles and can bear the light of day. The content of your character is your choice. Day by day, what you do is who you become. Your integrity is your destiny - it is the light that guides your way. - Heraclitus
 
Consider Paul's rocket mass heater.
 
subject: WSAD 5.1.x --> JDK 1.5???