aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Lomboz - Eclipse - XDoclet - need help... Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Lomboz - Eclipse - XDoclet - need help..." Watch "Lomboz - Eclipse - XDoclet - need help..." New topic
Author

Lomboz - Eclipse - XDoclet - need help...

Madhav Lakkapragada
Ranch Hand

Joined: Jun 03, 2000
Posts: 5040
Trying to setup the XDoclet (2.1.3) stuff with the Lomboz but running into some unknown issue. This is what I am doing -

Windows -> Preferences -> J2EE Annotations -> XDoclet

Form displays the following :

version: 1.2.1 [I want to change this to 1.2.3, which is the version I have installed C:\xdoclet-1.2.3]
XDoclet Home: C:\xdoclet-1.2.3

[OK]

'Unknown error occurred. Look at the error log.'

Any help is greatly appreciated. Is there some other place that I need to change some preference or something?
I am following the steps in the WTP tutorials.
Thanks.

- m


Take a Minute, Donate an Hour, Change a Life
http://www.ashanet.org/workanhour/2006/?r=Javaranch_ML&a=81
Madhav Lakkapragada
Ranch Hand

Joined: Jun 03, 2000
Posts: 5040
Ok, I figure out where the error log is. And this is what it has -

!ENTRY org.eclipse.jface 4 0 2005-06-20 09:10:11.46
!MESSAGE java.lang.IllegalArgumentException: Index out of bounds
!STACK 0
java.lang.IllegalArgumentException: Index out of bounds
at org.eclipse.swt.SWT.error(SWT.java:2844)
at org.eclipse.swt.SWT.error(SWT.java:2783)
at org.eclipse.swt.SWT.error(SWT.java:2754)
at org.eclipse.swt.widgets.Widget.error(Widget.java:393)
at org.eclipse.swt.widgets.Combo.getItem(Combo.java:568)
at org.eclipse.jst.j2ee.ejb.annotations.internal.xdoclet.ui.XDocletPreferencePage.performOk(XDocletPreferencePage.java:146)
at org.eclipse.jface.preference.PreferenceDialog$12.run(PreferenceDialog.java:843)
at org.eclipse.core.internal.runtime.InternalPlatform.run(InternalPlatform.java:1021)
at org.eclipse.core.runtime.Platform.run(Platform.java:757)
at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:40)
at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:148)
[snip]

Any help is greatly appreciated.
TIA.

- m
 
Don't get me started about those stupid light bulbs.
 
subject: Lomboz - Eclipse - XDoclet - need help...