aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse start Up error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Reply locked New topic
Author

Eclipse start Up error

Ganesh Gowtham
Ranch Hand

Joined: Mar 30, 2005
Posts: 225

Hi All.
Pls try to figure out the problem in ellipse..
When i tried to open the i got following log... which restricts me to load the eclipse..
Pls do let me know the problem...

!SESSION Jul 03, 2005 00:27:27.546 ---------------------------------------------
eclipse.buildId=M200409161125
java.version=1.3.1_01
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

!ENTRY org.eclipse.osgi Jul 03, 2005 00:27:27.546
!MESSAGE Error registering XML parser services.
!STACK 0
java.lang.ClassNotFoundException: javax.xml.parsers.SAXParserFactory
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at org.eclipse.core.runtime.adaptor.EclipseAdaptor.registerEndorsedXMLParser(EclipseAdaptor.java:272)
at org.eclipse.core.runtime.adaptor.EclipseAdaptor.frameworkStart(EclipseAdaptor.java:253)
at org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:61)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:958)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:954)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:937)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:553)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:477)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:273)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.launch(StartLevelManager.java:243)
at org.eclipse.osgi.framework.internal.core.SystemBundle.resume(SystemBundle.java:166)
at org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:425)
at org.eclipse.osgi.framework.internal.core.OSGi.launch(OSGi.java:51)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:216)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:127)
at java.lang.reflect.Method.invoke(Native Method)
at org.eclipse.core.launcher.Main.basicRun(Main.java:185)
at org.eclipse.core.launcher.Main.run(Main.java:704)
at org.eclipse.core.launcher.Main.main(Main.java:688)

!ENTRY initial@reference:file:e:/software/javareleated/eclipse-SDK-3.0.1-win32/eclipse/plugins/org.eclipse.core.runtime_3.0.1/ 0 0 Jul 03, 2005 00:27:27.937
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.core.internal.runtime.PlatformActivator.start() of bundle org.eclipse.core.runtime.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:975)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:937)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:421)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:366)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:999)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:577)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:488)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:273)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:444)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:186)
at org.eclipse.osgi.framework.eventmgr.EventThread.run(EventThread.java:104)
Root exception:
java.lang.NoClassDefFoundError: org/xml/sax/SAXException
at org.eclipse.core.internal.runtime.PlatformActivator.startRegistry(PlatformActivator.java:143)
at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:65)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:958)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:954)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:937)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:421)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:366)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:999)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:577)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:488)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:273)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:444)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:186)
at org.eclipse.osgi.framework.eventmgr.EventThread.run(EventThread.java:104)

!ENTRY initial@reference:file:e:/software/javareleated/eclipse-SDK-3.0.1-win32/eclipse/plugins/org.eclipse.update.configurator_3.0.0/ 0 0 Jul 03, 2005 00:27:28.00
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.update.internal.configurator.ConfigurationActivator.start() of bundle org.eclipse.update.configurator.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:975)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:937)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:421)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:366)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:999)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:577)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:488)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:273)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:444)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:186)
at org.eclipse.osgi.framework.eventmgr.EventThread.run(EventThread.java:104)
Root exception:
java.lang.Exception: Cannot initialize the Update Configurator
at org.eclipse.update.internal.configurator.ConfigurationActivator.initialize(ConfigurationActivator.java:93)
at org.eclipse.update.internal.configurator.ConfigurationActivator.start(ConfigurationActivator.java:71)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:958)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:954)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:937)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:421)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:366)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:999)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:577)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:488)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:273)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:444)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:186)
at org.eclipse.osgi.framework.eventmgr.EventThread.run(EventThread.java:104)

!ENTRY org.eclipse.osgi Jul 03, 2005 00:27:28.31
!MESSAGE Startup error
!STACK 1
java.lang.IllegalStateException: Bundle initial@reference:file:e:/software/javareleated/eclipse-SDK-3.0.1-win32/eclipse/plugins/org.eclipse.core.runtime_3.0.1/ [1] is not active.
at org.eclipse.core.runtime.adaptor.EclipseStarter.ensureBundlesActive(EclipseStarter.java:303)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:227)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:127)
at java.lang.reflect.Method.invoke(Native Method)
at org.eclipse.core.launcher.Main.basicRun(Main.java:185)
at org.eclipse.core.launcher.Main.run(Main.java:704)
at org.eclipse.core.launcher.Main.main(Main.java:688)



Thanks
Gowthamam i missing anythinf to keep in CLASSPATH
[ July 01, 2005: Message edited by: Gowtham Ganamukala ]

Thanks, Ganesh Gowtham
http://ganesh.gowtham.googlepages.com
Todd Farmer
Ranch Hand

Joined: May 28, 2004
Posts: 59
I've had that problem twice now. I believe I ended up resolving it by reinstalling the JDK. The class that your error message references is found in the rt.jar file. In my distribution of the 1.4.2_07 JDK, that's at:

C:\j2sdk1.4.2_07\jre\lib\rt.jar

Also, I think at least once this happened to me after I had installed an Oracle client app on my machine. I found that Oracle puts the path to its JRE at the front of the Windows PATH environment variable, which can cause all sorts of problems (can't remember if this was the root cause of this problem, though). I take the Oracle entry and put it at the end of the PATH environment variable entry.

Hope that helps.



Todd Farmer
Ernest Friedman-Hill
author and iconoclast
Marshal

Joined: Jul 08, 2003
Posts: 24166
    
  30

Don't know what inspired you to open a new thread for this. The problem is already diagnosed in your other thread. All you have to do is fix it. If you tried what was recommended there, and it didn't work, then go describe exactly what you did so people can tell you where you went wrong.


[Jess in Action][AskingGoodQuestions]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse start Up error
 
Similar Threads
eclipse startup error
Eclipse start Up error
Eclipse 3.0 Installation problems
Trouble when Opening Eclipse
Getting error org.eclipse.update.configurator_3.0.0/ [2] is not active