• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Checked out CVS project not Java one

 
Edmund Yong
Ranch Hand
Posts: 164
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I checked out a project from CVS into Eclipse. Apparently Eclipse does not treat this as a Java project even though it is. So, whenever I typed something in the editor followed by a "." (for example, "System."), a window will appear with the following message:

This compilation unit is not on the build path of a Java project.

Also, since Eclipse does not treat this as a Java project, it does not do auto build and other stuff like code completions etc.

What can I do to get Eclipse to treat it as a Java project?

Thanks
 
Ilja Preuss
author
Sheriff
Posts: 14112
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Make sure that you didn't check in the .project file (or delete it from CVS). Remove the project from the workspace.

Check it out again, using the option with the three dots (...) at the end. Eclipse should now notice that it isn't configured for Eclipse and show you a wizard to do so. Don't click "finish", but "next", until you come to the page where you can configure the project nature. Make it a java project. Voila.
 
Aruneesh Salhotra
Ranch Hand
Posts: 167
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
use the "check out as" in eclipse in the CVS repository and use the wizard.
After specifying info about the CVS, it will ask you how to check out the project, choose "Java Project".
VOILA again.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic