This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Eclipse and its keyboard language settings

 
Dirk Schumacher
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello out there,

I've been using eclipse quite a while.
There's one huge mystery around it for me.
When traveling with my fingers over the keyboard using lots of shortcuts it often happens that the language settings just magically change to english.
I know I am not always hitting the right shortcuts what makes me think that I change the language settings by accident. But I never figured by exactly which combination of keys I change it.
I use the german settings on windows. I figured it might be an OS problem but when restarting eclipse it all works out fine again. I figure that it has to deal with eclipse.
No one of the ecplise users know how to change this setting though they know the problem.
Is there any help out there for me?
 
Ilja Preuss
author
Sheriff
Posts: 14112
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Alt-Shift is the Windows default shortcut for changing the keyboard layout, if I remember correctly.

Try disabling this shortcut (the following is for XP):

- Start/Control Panel/Regional and Language Options
- Languages
- Details...

Now you should see that both German and English keyboard settings are installed. Either de-install the English settings, or use the button below to change/disable the key settings.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic