It's not a secret anymore!*
The moose likes IDEs, Version Control and other tools and the fly likes The WebLogic Server did not start up properly.java.io.Invalid Class Exception...? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "The WebLogic Server did not start up properly.java.io.Invalid Class Exception...?" Watch "The WebLogic Server did not start up properly.java.io.Invalid Class Exception...?" New topic
Author

The WebLogic Server did not start up properly.java.io.Invalid Class Exception...?

Mallik Avula
Ranch Hand

Joined: Nov 30, 2006
Posts: 86
Hi friends i am using MyEclipse 5, eclipse3.2 and Weblogic 8.1
when i start the weblogic normally it is running fine, but if i start it from MyEclipse it is giving the following error .

The WebLogic Server did not start up properly.
java.io.InvalidClassException: javax.management.MBeanAttributeInfo; local class incompatible: stream classdesc serialVersionUID = 7043855487133450673, local class serialVersionUID = 8644704819898565848
at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:546)
at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1551)
at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1465)
at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1551)
at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1465)
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1698)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1304)
at java.io.ObjectInputStream.readArray(ObjectInputStream.java:1633)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1298)
at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1917)
at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1841)
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1718)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1304)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:349)
at weblogic.management.internal.TypesHelper.getMBeanInfo(TypesHelper.java:261)
at weblogic.management.internal.TypesHelper.getAdminOrConfigMBeanInfo(TypesHelper.java:366)
at weblogic.management.internal.ConfigurationMBeanImpl.<init>(ConfigurationMBeanImpl.java:128)
at weblogic.management.AdminServer.<init>(AdminServer.java:59)
at weblogic.management.AdminServerAdmin.initialize(AdminServerAdmin.java:245)
at weblogic.t3.srvr.T3Srvr.initializeHere(T3Srvr.java:753)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:664)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:342)
at weblogic.Server.main(Server.java:32)
--------------- nested within: ------------------
weblogic.management.configuration.ConfigurationException: - with nested exception:

why this is? how to solve this?
plase waiting for replies?

Regards
Mallik Avula


Thanks & Regards<br />Mallik Avula<br />SCJP1.4
Nathan Pruett
Bartender

Joined: Oct 18, 2000
Posts: 4121

The first thing to check is to make sure that Eclipse and Weblogic are running in the same JVM version. (i.e. both 1.4 or 1.5, etc.)


-Nate
Write once, run anywhere, because there's nowhere to hide! - /. A.C.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: The WebLogic Server did not start up properly.java.io.Invalid Class Exception...?
 
Similar Threads
Weblogic 7 with jdk 1.6 - Does it support jdk 1.6?
Starting Weblogic in MyEclipse
WebLogic 7.0 did not start up using eclipse 3.1
problem in cofiguration of webllogic in myeclipse
My Weblogic ebLogic Server did not start up properly.