File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes Problem: Starting Sun App server 8.2 in Debug mode in Eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Problem: Starting Sun App server 8.2 in Debug mode in Eclipse" Watch "Problem: Starting Sun App server 8.2 in Debug mode in Eclipse" New topic
Author

Problem: Starting Sun App server 8.2 in Debug mode in Eclipse

Aju Joseph
Greenhorn

Joined: Feb 20, 2004
Posts: 6
Hi,

I am using Eclipse 3.3 (Europa) and have installed the glassfish pluggin for sun app servers. I have installed sun App server 8.2. Now in Eclise, I create a new server instance for sun app server 8.2, I try to start the server instance in debug mode in Eclipse, but I get the below error:



I tried the same with Glassfish server (sun app server 9.1) and I was able to start the server in debug mode through Eclipse successfully.

Tried to dig in the plugin jars and found that for for sun app server 8.2 server definition xml contained an element <debugport> which had value 567 where as for sun app server 9.1 the same element had value 9009. While starting the servers, did a netstat to figure out if the ports are in use, and I did not see any other process using the port 567 or 9009. Am able to start server 9.1 in debug mode but not server 8.2

Can any body help ???

Thanks,
Aju
 
Don't get me started about those stupid light bulbs.
 
subject: Problem: Starting Sun App server 8.2 in Debug mode in Eclipse