Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

trying to install emf template code generator but can't due to jdt file

 
Sarah Connor
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI guys,
I'm missing some emf plugs and want to try to up date my plugs accordingly.

I'm using the update manager for this
Help->Software Updates...->Find and install->Search for new features to install

then I add in the link
http://download.eclipse.org/modeling/emf/updates/site-interim.xml

Then at the next step it prompts me for a mirror where upon I use the link
http://download.eclipse.org/modeling/emf/updates/site-interim.xml

The update manager then starts to run

However it then generates a configuration error
When you look at the details it begings

Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced.
See details for more information.
----- Current configuration problems -----

Graphical Modeling Framework (Callisto Edition) (1.0.3.v20070202-1200) requires feature "org.eclipse.jdt (3.2.0)", or later version.

Eclipse Platform Plug-in Developer Resources (Windows) (2.1.3) requires plug-in "org.eclipse.platform.source (2.1.3)", or compatible.
Eclipse SDK Examples (Windows) (2.1.1) requires plug-in "org.eclipse.platform (2.1.1)", or compatible.
Eclipse Plug-in Development Environment (2.1.3) requires plug-in "org.eclipse.platform (2.1.0)", or compatible.
Eclipse Platform (Windows) (2.1.3) requires plug-in "org.eclipse.platform (2.1.3)", or compatible.
Eclipse Java Development Tools (2.1.3) requires plug-in "org.eclipse.platform (2.1.1)", or compatible.
Eclipse SDK Examples (2.1.1) requires plug-in "org.eclipse.platform (2.1.1)", or compatible.
----- Configuration problems after the operation -----
Graphical Modeling Framework (Callisto Edition) (1.0.3.v20070202-1200) requires feature "org.eclipse.jdt (3.2.0)", or later version.
Eclipse Platform Plug-in Developer Resources (Windows) (2.1.3) requires plug-in "org.eclipse.platform.source (2.1.3)", or compatible.
Eclipse SDK Examples (Windows) (2.1.1) requires plug-in "org.eclipse.platform (2.1.1)", or compatible.
Eclipse Plug-in Development Environment (2.1.3) requires plug-in "org.eclipse.platform (2.1.0)", or compatible.
Eclipse Platform (Windows) (2.1.3) requires plug-in "org.eclipse.platform (2.1.3)", or compatible.
Eclipse Java Development Tools (2.1.3) requires plug-in "org.eclipse.platform (2.1.1)", or compatible.
Eclipse SDK Examples (2.1.1) requires plug-in "org.eclipse.platform (2.1.1)", or compatible.
Eclipse Modeling Framework (EMF) Extender SDK (2.4.0.v200710041746) requires feature "org.eclipse.platform (3.3.0.v20061208-Fj22sCYGm0XDWm3)", or compatible.
Eclipse Modeling Framework (EMF) Runtime + End-User Tools (2.4.0.v200710041746) requires feature "org.eclipse.platform (3.3.0.v20061208-Fj22sCYGm0XDWm3)", or compatible.
Eclipse Modeling Framework (EMF) Examples (2.4.0.v200710041746) requires feature "org.eclipse.platform (3.3.0.v20061208-Fj22sCYGm0XDWm3)", or compatible.

I'm assuming its because my jdt file is out of date (first error on the line?) but I'm not sure.

Any help would be greatefully appreciated.

Sorry if this is a complete numpty question but CLUELESS and have searched every where on the internet all afternoon for a solution but to no avail.
 
Sarah Connor
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Got it working now (don't know how)... only problem is that I now have have two versions of emf and I'm trying to get rid of the older version.

Tune in for the next post!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic