wood burning stoves*
The moose likes IDEs, Version Control and other tools and the fly likes Using Weblogic with Eclipse-WTP Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Using Weblogic with Eclipse-WTP" Watch "Using Weblogic with Eclipse-WTP" New topic
Author

Using Weblogic with Eclipse-WTP

Soumya Manjunath
Ranch Hand

Joined: Nov 28, 2007
Posts: 34
Hello Everybody,

My question itself says that I'm new to this technology.I did search for answers before posting my doubt here.But couldn't find the exact answer.

I downloaded Eclipse-WTP from eclipse-jee-europa-fall2-win32.zip

How do I get this Eclipse-WTP work with Weblogic.? I mean where/how do I check this..?

I tried 2 ways.
1)File->New->Project->Web->Dynamic Web Project->Target Runtime.When I clicked the New button in front of it, it shows the options Apache,Basic, IBM,JBoss,ObjectWeb,Oracle. I don't see the option for Weblogic server.

Other one is
2)Window->Preferences->Server->Installed Runtimes->Add-> it shows the options Apache,Basic,IBM,JBoss,ObjectWeb,Oracle. I don't see the option for Weblogic server.

I'm I missing out something or does it mean that I've to download Weblogic plugin and install it.

My apologies if I'm trying to bring up the same issue discussed previously.


Thanks & Regards,<br />Soumya.
Jesper de Jong
Java Cowboy
Saloon Keeper

Joined: Aug 16, 2005
Posts: 14074
    
  16

Welcome to JavaRanch.

Try this: Window / Preferences / Server / Installed Runtimes / Add...

In the dialog "New Server Runtime", there is a link "Download additional server adapters". Click it, and Eclipse will search on the Internet for additional server adapters. When it's done there should be one or more adapters for Weblogic in the list. Install the appropriate one.


Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 7 API documentation
Scala Notes - My blog about Scala
Soumya Manjunath
Ranch Hand

Joined: Nov 28, 2007
Posts: 34
Thanks Jesper.I downloaded and installed the tools.

Now when I choose Weblogic as my Target Runtime and c:\bea as Weblogic Home
it shows an error "The path 'c:\bea' doesn't contain a valid weblogic server install."

I tried starting the server and then assigning the Targer Runtime.But the error remains the same.

I've Weblogic 10.0 under c:\bea and Eclipse 3.3 on my machine.
Any help is appreciated.
[ November 30, 2007: Message edited by: Soumya Manjunath ]
lata lokhande
Greenhorn

Joined: Aug 04, 2008
Posts: 1
I am trying the same to download the adapter for Weblogic Server 8.1 for WTP 3.0. When I click on "download additional server adapter" link from New Server Runtime Environment wizard, getting error saying could not connect.

Any help is appreciated in this matter to get the weblogic server support for Web tools platform.

Thanks in advance,
Lata
Quincy Acklen
Greenhorn

Joined: Aug 15, 2002
Posts: 12
Soumya,
it's probably way too late to help you, but maybe the next person will benefit.

"The path 'c:\bea' doesn't contain a valid weblogic server install."


I think it's looking for 'c:\bea\weblogic81' (or whatever version you may have - I'm running 8.1.6 which installs some files into bea, and other files into bea\weblogic81 - which is what eclipse is looking for. In any event that's what worked for me.

That said I still have problems later...


Lata, I'm guess that you're running behind a firewall and have to use a proxy to get out to the internet (big companies tend to like web logic and also have that security in place). You can change your proxy server settings (in eclipse 3.4) by selected Window > Preferences > General > Network Connections > Manual Proxy Configuration. The System Proxy Configuration didn't work for me (even though it does with most other apps). Even still I had a one or two locations that couldn't connect but most did after that change.
Quincy Acklen
Greenhorn

Joined: Aug 15, 2002
Posts: 12
As for my problem...

After downloading and installing the Weblogic Adapter, it doesn't show up in the list of servers to use. And _now_ it does NOT show up in the list of adapters to download and install. The download seemed to work just fine. It installed and restarted Eclipse, but never became available. Otherwise weblogic is working fine and I currently have my app deployed on it just fine (from the workspace as an exploded war).
Jon Entwistle
Ranch Hand

Joined: Feb 20, 2003
Posts: 118
Hi Quincy,

I am guessing that you have installed using eclipse ganymede. The plugin is only compatible with version M5 and not the final release. This is due to the incorporation of BEA into Oracle, as they are incorportating this plugin into the oracle set of tools instead of updating the BEA set.

http://forums.bea.com/thread.jspa?threadID=5700001945

Solution: downgrade to eclipse europa, or use the BEA workschop eclipse release that comes with the weblogic server (or downloaded seperately for free).

Cheers,

Jon


SCJD, SCEA
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Using Weblogic with Eclipse-WTP
 
Similar Threads
Environment setup/configuration
Is Eclipse really this hard? And how did it get so popular?
Cannot see web project option in eclipse 3.6
Dynamic Web Project
Eclipse - Server not available on Run on Server