my dog learned polymorphism*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse - Server not available on Run on Server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse - Server not available on Run on Server" Watch "Eclipse - Server not available on Run on Server" New topic
Author

Eclipse - Server not available on Run on Server

RoshaniG Gopal
Ranch Hand

Joined: May 15, 2006
Posts: 180
Hi all,
I have a customised application server that is created as a plugin and integrated in the eclipse 3.3.1.1 build 20071023. After installing the plugin, I can view the app server in the server view. I can select the server, create a new server instance and also run it correctly.
1) The problem comes when I try to run it on Dynamic web project> Run on Server; I do not get a option of running it on the existing server. The dialog box asks me to create a new server instance. 2) If I select the new server (any app server)from the dialog box, and point the application server directory to the my application server; it works perfectly fine. The plugin for the app server was developed and tested successfully on Eclipse 3.1 with WTP 0.7 version. But on upgrade to Eclipse Europa (Eclipse 3.3.1 build 20071023), i am facing this problem.
Is it due to the different WTP versions or some configuration files missing at my end that were required for the Eclispse 3.3 plugin envoirnment. (PS: I have already checked for the plugin migration guides).
Kindly help me resolve this issue.
Kind regards,
Roshani


Regards,<br />Roshani
Taylor James
Greenhorn

Joined: Mar 17, 2008
Posts: 1
Did you ever find a solution to the missing server tab/option? I'm having the same issue after upgrading.

Thanks, T
[ March 17, 2008: Message edited by: Taylor James ]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse - Server not available on Run on Server
 
Similar Threads
Do you use in maven ear to build your ear in dev env?
404 error + Cannot find JSP
another Eclipse & JBoss question
Java EE 5 server
Eclipse interaction with Tomcat - cannot undeploy applications