File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes jstl in eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Reply locked New topic
Author

jstl in eclipse

Shashi Ranjan
Greenhorn

Joined: Jun 12, 2007
Posts: 8
Hi,

I'm unable to use jstl in eclipse. It's not recognising the uri="http://java.sun.com/jsp/jstl/core".Although I've put the jstl.jar in WEB-INF/lib. Alternatively I've also tried to set the jstl.jar in run time dependencies............I'm waiting for reply.

Thanks
Shashi Ranjan
Greenhorn

Joined: Jun 12, 2007
Posts: 8
I just added c.tld in WEB-INF/lib and it worked.
Christophe Verré
Sheriff

Joined: Nov 24, 2005
Posts: 14687
    
  16

You should not extract the TLD ! You must add standard.jar in your PATH. Check this FAQ.


[My Blog]
All roads lead to JavaRanch
Pravin Bansal
Greenhorn

Joined: Nov 16, 2009
Posts: 2
Guys,
Eclipse error "Cannot find the tag library descriptor for "http://java.sun.com/jsp/jstl/core" ideally have couple of reasons, most of them have been pointed out in the previous posts, the one and particularly important is as below. (which was actually the case with me)
Having this added in your jsp
<%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c" %>
<%@ taglib uri="http://java.sun.com/jsp/jstl/functions" prefix="fn" %>
even after you have jstl.jar and standard.jar in the WEB-INF/lib directory, the only reason for this is the version of these two jar's.
defining taglib in the way "<%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c" %> " is required to have these jar's of version 1.2 (which are extracted from jakarta-taglibs-standard-1.1.2.zip) unfortunately you can never know the version of these jar's from their property
defining taglib in the way "<%@ taglib uri="http://java.sun.com/jstl/core" will require 1.0 version of these jar's.
Hope it helps.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5812
    
    7

Pravin, welcome to Java Ranch.

I know that you are trying to be helpful, but please don't wake the zombies.


JBoss In Action
Junaid Kirkire
Greenhorn

Joined: Mar 26, 2009
Posts: 7
I am using IBM RAD7.5 and WebSphere application server 7.0. I have been to the Project Facets options and activated JavaServer Faces 1.1 and JSTL 1.1.

I am trying to use the code given in HeadFirst Servlets and JSPs.

My code is as follows-->

<%@ page language="java" contentType="text/html; charset=ISO-8859-1"
pageEncoding="ISO-8859-1"%>
<%@ taglib prefix="f" uri="http://java.sun.com/jsf/core"%>
<%@ taglib prefix="h" uri="http://java.sun.com/jsf/html"%>

<%@ taglib prefix="mine" uri="DiceFunctions"%>
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<title>Insert title here</title>
</head>
<body>
<f:view>
${ mine:rollIt()_ }
</f:view>
</body>
</html>

Only the text colored in red shows error. Rest is fine. The first error is that 'cannot find taglib descriptor' and the second is 'EL syntax error'.

Please tell me how to solve this problem.

Also, is there a standard way of making TLDs in Eclipse or RAD? I have made it manually by saving an XML file as .tld

Please help. Thanks!
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5812
    
    7

Junaid, please ask this question in a new topic.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: jstl in eclipse
 
Similar Threads
Error with JSTL tags in eclipse
frustrated w/ JSTL
Cannot import Taglib JSTL
JSTL functions
error while running jsf application