Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

getting error in linking the jsp page

 
Geeta Ravikanti
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I want to link the jsp page in the HTML tag
i.e when I clicked the tab it has go to the jsp page
In general we wrote any link like following

<LI><A href="http://www.dynamicdrive.com/forums/">Forums</A>

i.e when I clicked on the forums tab it will directly goes to the related website
but I want link forums tab with JSP page
For this I wrote like this

<LI><a href="<s:url value="User.jsp"/>">Forums</A></li >

but its showing error(i.e red color line)

Any Help in this its highly appriciated

Regards
Geeta R
 
Anirvan Majumdar
Ranch Hand
Posts: 261
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Geeta Ravikanti:

For this I wrote like this

<LI><a href="<s:url value="User.jsp"/>">Forums</A></li >

but its showing error(i.e red color line)


I don't think you really need to be bothered about your Editor showing a "red-color line", since the <s:url/> tag will first be translated to its corresponding text/HTML value before it is sent to the browser. The red-color line you're seeing is most probably because of the occurrence of the character " within an attribute value which is also bound by ". To remove it, you can try and set the href attribute's value within ' instead of ".
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic