jQuery in Action, 2nd edition*
The moose likes IDEs, Version Control and other tools and the fly likes Upgrade wsad with java 1.5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Upgrade wsad with java 1.5" Watch "Upgrade wsad with java 1.5" New topic
Author

Upgrade wsad with java 1.5

Mortin kim
Ranch Hand

Joined: Nov 15, 2007
Posts: 44
Hi
I am Using WSAD 5.1
I wanted to upgrade it with java 1.5
can any one please tell how to do it..?

What I did is :
I installed the java 1.5 in my machine any from WSAD -> window -> preference -> java ->Installed JREs
I pointed new new installed jre dir (C:\Program Files\Java\jdk1.5.0_15\jre\lib)
and when I am trying run my java programe it is giving the fallowing error

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

Hope you you under the problem


KIM.
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 30123
    
150

Mortin,
WSAD 5 doesn't support Java 5. You need to upgrade to RAD 7. (They renamed WSAD to RAD.)

It is not possible to upgrade the WSAD server JVM in any supported way. While you can change the compiler, the IDE does not know about Java 5 keywords and you will still get errors.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Upgrade wsad with java 1.5
 
Similar Threads
WSAD 5.1.x --> JDK 1.5???
Enum problem
SCJP 5 Upgrade Question
WSAD and JDK 1.4
Parameterising in ArrayList throws error