aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes run servlet in tomcat 5.5 in eclipse 3.2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "run servlet in tomcat 5.5 in eclipse 3.2" Watch "run servlet in tomcat 5.5 in eclipse 3.2" New topic
Author

run servlet in tomcat 5.5 in eclipse 3.2

joseph prabhu
Ranch Hand

Joined: Feb 26, 2008
Posts: 162
joseph here

i have eclipse 3.2 with tomcat 5.5 version server plugin.


i am able to run jsp's but i am not able to run servlet.

i right clicked the root directory and have new servlet.
it shows the following 404 error. what i have to do. how to write the servlets.
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16134
    
  21

You didn't list the 404 error, and in particular the URL.

If you were hoping that servlets could be found just by typing their names, that was an insecure feature that's no longer supported in Tomcat. You now need to explicitly define the servlet and its relative URL in web.xml.


Customer surveys are for companies who didn't pay proper attention to begin with.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: run servlet in tomcat 5.5 in eclipse 3.2