Meaningless Drivel is fun!*
The moose likes IDEs, Version Control and other tools and the fly likes How to use Eclipe with WebSphere6.1 or WebLogic 10 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "How to use Eclipe with WebSphere6.1 or WebLogic 10" Watch "How to use Eclipe with WebSphere6.1 or WebLogic 10" New topic
Author

How to use Eclipe with WebSphere6.1 or WebLogic 10

P Sathish Kumar
Greenhorn

Joined: Sep 08, 2007
Posts: 14
Hi,
I am new to j2EE yestaday i download Websphere 6.1 and WebLogic 10.since they are very popular. I could not add this servers in Eclipse its seen that eclipse has support for WebSphere 6 and there is no option in the add server for WebLogic. I am confused. Can any one help me out.

Regard
Sathish kumar
Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 30764
    
156

Sathish,
You could create a war/ear file in Eclipse and deploy that to your server. Or you could search for a plugin that lets you integrate Eclipse with your server.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
Alaa Nassef
Ranch Hand

Joined: Jan 28, 2008
Posts: 467
If you have Eclipse WTP, go to Window->Preferences->Servers->Installed Runtimes, click the "Add" button, then click on the "Download additional server adapters". You should get a list of several adapters from the web, including "Oracle Weblogic"


Visit my blog: http://jnassef.blogspot.com/
Pankaja Shinde
Ranch Hand

Joined: Sep 15, 2006
Posts: 87
Error : Integration of Websphere Application Server V 6.0 in Eclipse 3.4.0 or MyEclipse 5.5.1 GA

When I am integrating WAS 6.0 in Eclipse 3.4.0 I am getting error as

The java class is not found:
D:/Program Files/IBM/WebSphere/AppServer1/java/jre/lib/ext/ibmorb/jar;

Please suggest me solution.

I also tried adding ibmorb.jar file externally in classpath.
I used JRE from IBM websphere installation directory.
I tried same in MyEclipse 5.5.1 GA, but same problem.


Regards

Pankaj Shinde
[ August 24, 2008: Message edited by: Pankaja Shinde ]
Pankaja Shinde
Ranch Hand

Joined: Sep 15, 2006
Posts: 87
The problem is with virtual machine (VM) arguments.
One or more VM arguments in the arguments tab of the launch configuration properties lack quotes around them.

In my case it was with

-Xbootclasspath/p :/Program Files/IBM/WebSphere/AppServer1/java/jre/lib/ext/ibmorb.jar;D:/Program Files/IBM/WebSphere/AppServer1/java/jre/lib/ext/ibmext.jar -Xms50m -Xmx256m

Add quotes around these arguments.

Regards

Pankaj Shinde
[ August 27, 2008: Message edited by: Pankaja Shinde ]
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: How to use Eclipe with WebSphere6.1 or WebLogic 10