File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes IDEs, Version Control and other tools and the fly likes tomcat+eclipse problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "tomcat+eclipse problem" Watch "tomcat+eclipse problem" New topic

tomcat+eclipse problem

Giuseppe Scalese

Joined: Oct 19, 2008
Posts: 1
I have installed ecplise ganymede with tomcat as application server and jdk5. But, If i try to add a "runtime environment" from the 'preferences' both tomcat 5.5 and 6.0 doesn't works.
If i try to set the first one this message is shown : "The Tomcat installation directory is not valid. It is missing expected file or folder common/i18n"

If i try to set the second one this message is shown : "The Tomcat installation directory is not valid. It is missing expected file or folder lib/jasper-el.jar"

I have tried also to use the 'Sysdeo Eclipse Tomcat Launcher plugin' but it doesn't works anyway.

Is there anyone who could help me?

thank you!

Bear Bibeault
Author and ninkuma

Joined: Jan 10, 2002
Posts: 63838

"beppe", please check your private messages for an important administrative matter.

[Asking smart questions] [About Bear] [Books by Bear]
Peter Johnson

Joined: May 14, 2008
Posts: 5852

I checked my Tomcat 5.5 and 6.0 installation directories, and sure enough the file/directory mentioned is present. Therefore, I have to ask, how did you install Tomcat? What operation system are you running?

My first thought is that you might be running Linux and used a package manage to install Tomcat and the resulting directory structure might be different that what Eclipse expects (I would check on my copy of Kubuntu to see if this is the case but I never use the package manager to install any Java-related packages). The solution would be to download Tomcat form the Apache web site and install it manually.

If none of this helps, do a "dir" or "ls -al" on the Tomcat home directories and post those.

JBoss In Action
Abhik Ghosh
Ranch Hand

Joined: Feb 28, 2008
Posts: 32
Hi.. I just found a soln to the problem... within the folder apache-tomcat-6.0.20 there is another point your root dir to the second folder , in my case it is E:\apache-tomcat-6.0.20\apache-tomcat-6.0.20... and the problem is solved.
I agree. Here's the link:
subject: tomcat+eclipse problem
It's not a secret anymore!