wood burning stoves 2.0*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse 3.4 WTP Big Headache Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse 3.4 WTP Big Headache" Watch "Eclipse 3.4 WTP Big Headache" New topic
Author

Eclipse 3.4 WTP Big Headache

Bo Larson
Greenhorn

Joined: Oct 27, 2008
Posts: 14
Hi, I don't have much experience with Eclipse or WTP. A while back I downloaded the complete J2EE Eclipse package and have been running it successfully. I'm using a clean Tomcat 5.5.

I've been writing a web service that until yesterday was working just fine from Eclipse. That is, I created a web service via Eclipse WTP and could run it from Web Services Explorer. I also generated a client and was able to run it as well. No problems. Then I decided to rename my projects and everything went south.

My workspace has two projects in it. One is a Utility project that contains my model and a service facade. The other is a Dynamic Web Project that uses the facade from the Utility project. After renaming the projects, I now receive a NoClassDefFoundError and ClassNotFoundException for the facade class when I try to invoke the web service in Web Services Explorer or from my generated test clients.

All of my unit tests for both projects are fine.

I have tried the following (extreme) measures:

1) I completely removed Eclipse and Tomcat and unzipped fresh copies in fresh folders. In fact, I used Eclipse to install Tomcat.

2) I created a brand new workspace for the new Eclipse install.

3) I recreated my Utility and Dynamic Web projects and imported the source folders from the projects in the old workspace.

4) I regenerated the web service and clients.

Still no luck.

In brief, when I invoke my web service I'm getting an exception that my facade class in a separate project is not found. When I run unit tests on the class from which the web service was generated they all pass. Something must be hosed with the way that the service is being published to Tomcat... something that would persist through a reinstall of both Eclipse and Tomcat? Hmmm.
Bo Larson
Greenhorn

Joined: Oct 27, 2008
Posts: 14
Figured it out. My J2EE module dependencies were wiped out which initiated this whole mess.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Eclipse 3.4 WTP Big Headache