This week's book giveaway is in the Cloud/Virtualizaton forum.
We're giving away four copies of Mesos in Action and have Roger Ignazio on-line!
See this thread for details.
Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Help: Modern compiler is not available.

 
Brad Baker
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't undstand why I am geting this:
[javac] Modern compiler is not available - using classic compiler
Here is my build.xml

This is the full output:

My path is:
PATH=d:\java\jdk1.4.1\bin;d:\apache\ant-1.5.2\bin
So why does it say "Modern compiler is not available - using classic compiler"?
anyone?
Thanks,
 
Andy Bowes
Ranch Hand
Posts: 171
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you tried setting your JAVA_HOME environment variable as it suggests in the output ?
 
Brad Baker
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Andy,
My OS is Win2k with:
Set JAVA_HOME=d:\java\1.4.1
in my system environment.
I have:

in my build.xml and it gives me:
[echo] JavaHome: d:\java\jdk1.4.1
So as far as I can tell I have JAVA_HOME set.
What have I missed?
 
Dennis Rosa
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try this ..

<target name="compile" depends="init">
<javac srcdir="src"
destdir="build"
classpathref="siacc.class.path"
fork="true"
/>
</target>
ANT-Help....
Windows Note:When the modern compiler is used in unforked mode on Windows, it locks up the files present in the classpath of the <javac> task, and does not release them. The side effect of this is that you will not be able to delete or move those files later on in the build. The workaround is to fork when invoking the compiler.
Dennis
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic