aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes HOW TO SET PATH IN TOMCAT OF ANT BUILDER Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "HOW TO SET PATH IN TOMCAT OF ANT BUILDER" Watch "HOW TO SET PATH IN TOMCAT OF ANT BUILDER" New topic
Author

HOW TO SET PATH IN TOMCAT OF ANT BUILDER

narasimharao konjeti
Ranch Hand

Joined: Apr 26, 2003
Posts: 130
Hi, I have one doubt. I am using tomcat as app.web server and ant as a build tool. When I am building .jar,.war,.ear files from command prompt is is working properly. and When I am working with tomcat, it is not building, and whenever I am setting classpath in setclasspath.bat in tomcat,server is not running it is telling access denied, if i give small path. server is working properly. I could able to get the problem. can anyone help me. in this issue.


"Unwise to sweat petty stuff, wise to pet sweaty stuff."
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 15642
    
  15

I'm not sure I understood all that - I think there's some further information I might need to know, but you did say that things work with a short classpath.
If you're working with Windows, the default environment space is about 2048 characters, and that's often too small. You can check this by typing "echo %CLASSPATH%" at the command prompt. If you don't see the entire classpath, you'll need to enlarge your environment space.


Customer surveys are for companies who didn't pay proper attention to begin with.
prakash alluri
Greenhorn

Joined: Mar 12, 2003
Posts: 6
Hi,
This is what I did, when I installed tomcat on my system (windows 2000) and it is working fine.
in Environment Variables Tab,
under System variables:
set JAVA_HOME = your JDK home directory
set TOMCAT_HOME = your tomcat home directory
now try to start tomcat using startup located in bin directory of your tomcat home directory.
It should work.
good luck...
prakash alluri
Greenhorn

Joined: Mar 12, 2003
Posts: 6
hi
set TOMCAT_HOME in your user defined variables list under Environmet variables........not in system variables.
but set JAVA_HOME in system variables......
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: HOW TO SET PATH IN TOMCAT OF ANT BUILDER
 
Similar Threads
ant with tomcat
Setting Up Ant
Tomcat Ant tasks
Root apps on Tomcat using Ant
Path not working