aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes What am I doing wrong when setting the paths? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "What am I doing wrong when setting the paths?" Watch "What am I doing wrong when setting the paths?" New topic
Author

What am I doing wrong when setting the paths?

Fernando Sanz
Ranch Hand

Joined: Jun 27, 2003
Posts: 101
Hi there,
I've downloaded Ant and I'm trying to install it with Windows XP.
So far I have C:\Ant with all the folders.
Also, I system has these:
CLASSPATH
.;.;C:\PROGRA~1\JMF21~1.1\lib\sound.jar;C:\PROGRA~1\JMF21~1.1\lib\jmf.jar;C:\WINDOWS\java\classes;.
path
;C:\Program Files\STI\bin\pc-win95;C:\ant\bin
AUTOEXEC.BAT
set ANT_HOME=c:\ant
set JAVA_HOME=c:\jdk1.1.8
set PATH=%PATH%;%ANT_HOME%\bin
set CLASSPATH=.
But, when I try to run Ant, I get this message:
'ant' is not recognized as an internal or external command,
operable program or batch file.
so I assume I didn't do any of the Path stuff properly.
I'd really appreciate any help
Thanks!
Peter Storch
Ranch Hand

Joined: Jun 12, 2003
Posts: 74
Hmm, I don't know exactly what's wrong, but I suggest to use only one source for your environment varibales.
I wouldn't use the autoexec.bat on Windows XP anymore.
Try to set the environment variables only via your control panel.
Then open a command window and type "set" to check the environment variables.
Fernando Sanz
Ranch Hand

Joined: Jun 27, 2003
Posts: 101
Originally posted by Peter Storch:
Hmm, I don't know exactly what's wrong, but I suggest to use only one source for your environment varibales.
I wouldn't use the autoexec.bat on Windows XP anymore.
Try to set the environment variables only via your control panel.
Then open a command window and type "set" to check the environment variables.

You're right, those were two of the problems.
I've finally got Ant up and running.
Thanks
 
 
subject: What am I doing wrong when setting the paths?