aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes Ant 1.5.4 and JDK 1.3.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Ant 1.5.4 and JDK 1.3.1" Watch "Ant 1.5.4 and JDK 1.3.1" New topic
Author

Ant 1.5.4 and JDK 1.3.1

Wael Aoudi
Greenhorn

Joined: Mar 10, 2004
Posts: 4
I'm using an IDE that only supports jdk 1.3.1 but im using Ant 1.6. is that why my Ant generates errors and fails to build. same for the servlet api. At first i was having problems with jdk because i was using 1.4.2 and the servlet and "ant" were not generating errors. Is it because when i supplied the right jdk is when it actually looked at the servlet and "ant" and realised they are not the right ones. SO my question is does it matter which JDK i use with ANT? and if i'm using an old JDK can that cause the ant and servlet to fail?
I have Tomcat 5.0 installed. The error message includes "ant was compiled april 14th 2003" something like that i'm at work and dont have the program infront of me. Is that a sign that im using a new "ant" and its looking for an old version.
Thank you,
Wael Aoudi
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Ant 1.5.4 and JDK 1.3.1