Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
The moose likes Ant, Maven and Other Build Tools and the fly likes Ant jar signing issues Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Ant jar signing issues" Watch "Ant jar signing issues" New topic
Author

Ant jar signing issues

Gregg Bolinger
GenRocket Founder
Ranch Hand

Joined: Jul 11, 2001
Posts: 15299
    
    6

I am trying to sign a jar file with the ant task..
<signjar jar="${build.dir}\${name}.jar" alias="gthought" storepass="private" keystore="myKeystore" />
And I am getting the following error message...

Execute failed: java.io.IOException: CreateProcess: jarsigner.exe -keystore C:\projects\GLMod\myKeystore -storepass private C:\projects\GLMod\build\glmod.jar gthought error=2

If I do this from the command line and not with ANT it works fine. Anyone see what is going on?


GenRocket - Experts at Building Test Data
Thomas Paul
mister krabs
Ranch Hand

Joined: May 05, 2000
Posts: 13974
This seems to be right on topic:
http://www.coderanch.com/t/107138/tools/signjar-ant-eclipse-BUILD-FAILED


Associate Instructor - Hofstra University
Amazon Top 750 reviewer - Blog - Unresolved References - Book Review Blog
Gregg Bolinger
GenRocket Founder
Ranch Hand

Joined: Jul 11, 2001
Posts: 15299
    
    6

That's just strange. In IDEA I went to the settings and added a Path Variable of JAVA_HOME to my Java home directory. Now it works. That just seems strange to me since IDEA could find java.exe and javac.exe just fine. Oh well, works now. Thanks Tom for the link.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Ant jar signing issues
 
Similar Threads
ANT & Jarsigner error: "not a private key"
Jar signer
Signed Applet - Using same alias while development
Problem in Signing the Jar Files
Applet Signing problem