This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

ant script using "wsStopApplication" task doesnt run

 
sub venkat
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The ANT script below tries to stop an app named "testapp". I am running it on the host machine via "ws_ant". IT BOMBS. Any insight is really really appreciated..

____________________________________________________
Buildfile: /tmp/ant_test/stopapp.xml
____________________________________________________
<?xml version="1.0"?>
<project name="test_deploy2" default = "stopapp" basedir=".">



<target name="stopapp" >
<taskdef name="wsStopApplication" classname="com.ibm.websphere.ant.tasks.StopApplication"/>

<wsStopApplication
wasHome="a/b/c/AppServer"
application="testApp"
conntype="SOAP"/>


</target>

</project>
____________________________________________________

stopapp:

[wsStopApplication] Stopping Application [testApp]...

[wsadmin] WASX7209I: Connected to process "dmgr" on node xYZManager using SOAP connector; The type of process is: Deploym
entManager
[wsadmin] WASX7017E: Exception received while running file "/tmp/wsant57218jacl"; exception information: com.ibm.bsf.BSFExc
eption: error while eval'ing Jacl expression: com.ibm.ws.scripting.ScriptingException: WASX7025E: Error found in String "WebS
phere latform=common,cell=Lab,version=5.0,name=ApplicationManager,mbeanIdentifier=ApplicationManager,type=ApplicationM
anager,node=xYZ,process=GoodApp_TST_JVM_0
[wsadmin] WebSphere latform=common,cell=Lab,version=5.0,name=ApplicationManager,mbeanIdentifier=ApplicationManager,t
ype=ApplicationManager,node=xYZ,process=testapp_JVM_0
[wsadmin] WebSphere latform=common,cell=Lab,version=5.0,name=ApplicationManager,mbeanIdentifier=ApplicationManager,t
ype=ApplicationManager,node=xYZ,process=server1
[wsadmin] WebSphere latform=common,cell=Lab,version=5.0,name=ApplicationManager,mbeanIdentifier=ApplicationManager,t
ype=ApplicationManager,node=xYZManager,process=dmgr"; cannot create ObjectName.
[wsadmin] Java Result: 105

[wsStopApplication] Stopped Application [testApp]
____________________________________________________


thanks
Sub Venkat

 
sub venkat
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I did not include those green-alien smileys. I have no idea how they creeped in!!

Sub Venkat
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic