aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes UnsupportedClassVersionError error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "UnsupportedClassVersionError error " Watch "UnsupportedClassVersionError error " New topic
Author

UnsupportedClassVersionError error

Cathie Lee
Greenhorn

Joined: Nov 20, 2004
Posts: 8
I got the following error message when trying to build using ant.

Unable to load default ProjectHelper due to java.lang.UnsupportedClassVersionError: org/xml/sax/SAXException (Unsupported major.minor version 49.0

Does anybody know what's wrong? It was working fine with my build.xml. But now got this error.

My ant version: 1.6.2
My JDK: 1.3.1

Thanks in advance for your help.

Cathie
Carol Enderlin
drifter
Ranch Hand

Joined: Oct 10, 2000
Posts: 1364
Unsupported major.minor version 49.0 sounds like a java version mismatch somewhere in your build.
Ilja Preuss
author
Sheriff

Joined: Jul 11, 2001
Posts: 14112
Some class you are trying to use was compiled with Tiger.


The soul is dyed the color of its thoughts. Think only on those things that are in line with your principles and can bear the light of day. The content of your character is your choice. Day by day, what you do is who you become. Your integrity is your destiny - it is the light that guides your way. - Heraclitus
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: UnsupportedClassVersionError error