aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes Class bytes found but defineClass() failed Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Class bytes found but defineClass() failed " Watch "Class bytes found but defineClass() failed " New topic
Author

Class bytes found but defineClass() failed

sasikumar palakkizhi
Greenhorn

Joined: Sep 11, 2005
Posts: 29
Hi all,

I am using ant with eclipse to build a project. I am doing the project in eclipse from an existing source. For building the project, I have done the set up using External Tools dialog in eclipse.In my ant script, I am using a task defined as wlappc which is defined in weblogic.jar. I have added all the classes required. The version of weblogic is 8,jdk used is 1.4 and ant used is 1.7 ( I tried with 1.5 too).

Now I am getting the trace as given below. When I googled, I read that this can be caused by version incompatibility. But I am not very sure about this. What will be the cause of this and how can I correct it.

Thanking you in advance

sasi

chandra reddy
Greenhorn

Joined: Apr 11, 2007
Posts: 10
Hi sasikumar palakkizhi,

I too got the same error,i got resolved, this is version problem only.
We need to use the weblog java compiler,i mean weblogic java. we need to set that first in the path variable(path="C:\bea\jdk141_03\bin").

Thanks,
-Chandra.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Class bytes found but defineClass() failed