GeeCON Prague 2014*
The moose likes Ant, Maven and Other Build Tools and the fly likes Ant script not finding my build.properties file Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Ant script not finding my build.properties file" Watch "Ant script not finding my build.properties file" New topic
Author

Ant script not finding my build.properties file

Sege Stephen
Ranch Hand

Joined: Oct 06, 2007
Posts: 51
Hi, I have my ant Script, I am working through the spring tutorial.

The build.properties and build.xml are on the same level in my springapp package, but anytime it tries to read a value from the build.properties file, it comes up with any error.

Here is my ant Script

xml version="1.0"?

and here is the build.properties

appserver.home=${user.home}/apache-tomcat-6.0.18

appserver.lib=${appserver.home}/lib

deploy.path=${appserver.home}/lib

tomcat.manager.url=http://localhost:8080/manager
tomcat.manager.username=tomcat
tomcat.manager.password=s3cret


When I run ant, i get this error message

BUILD FAILED
C:\Documents and Settings\se1025\workspace\springapp\build.xml:87: C:\Documents
and Settings\se1025\workspace\springapp\${application.lib} not found.



i get this error when I run ant list if I substitue ${appserver.lib}with the value C:/apache-tomcat-6.0.18. It builds, then I run ant list and get this


list:


[ August 27, 2008: Message edited by: Sege Stephen ]
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5836
    
    7

Try running ant with the -v option, this might tell you a little more about what is going on.
[ August 27, 2008: Message edited by: Peter Johnson ]

JBoss In Action
 
jQuery in Action, 2nd edition
 
subject: Ant script not finding my build.properties file