aspose file tools*
The moose likes Linux / UNIX and the fly likes Jdk1.3 on linux Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "Jdk1.3 on linux" Watch "Jdk1.3 on linux" New topic
Author

Jdk1.3 on linux

Sean Casey
Ranch Hand

Joined: Dec 16, 2000
Posts: 625
I'm running redhat 7.0. I thought that I correctly installed the jdk1.3. At the command promt I issued: java -version it It said the jvm I was using was KAFFEE(i've never heard of it) and it said that the version of java was 1.1. Now I'm wondering if this came with my redhat package, because it clearly isn't jdk1.3. If this is the case, is there a classpath variable I need to edit and if so how can I edit that variable, and where is it. Any input would be greatly appreciated.
Thanks,'
Sean
Adrian Yan
Ranch Hand

Joined: Oct 02, 2000
Posts: 688
The JDK comes with redhat is jdk1.1, the Kaffee is linux port of jdk.
You need to donwload the jdk1.3 from sun and install on your linux box.
Frank Carver
Sheriff

Joined: Jan 07, 1999
Posts: 6920
You need to either modify the system PATH, or put links to the Sun java executables in place of the Kaffe ones. I did this with a RedHat 7 install recently, and it more than tripled the performance of my serverside Java apps, so it's well worth doing.
Do a "locate javac" to find where the executables are.


Read about me at frankcarver.me ~ Raspberry Alpha Omega ~ Frank's Punchbarrel Blog
ryan headley
Ranch Hand

Joined: Jun 28, 2000
Posts: 156
Heh,
I got it all installed, (had to upgrade to glibc 2.2.2, I don't think that went quite right which could be my problem but....)
Everytime I type javac hello.java I get a segmentation fault.
Anyone else ever gotten this problem??


Ryan Headley<br /><a href="http://www.sudovi.com" target="_blank" rel="nofollow">http://www.sudovi.com</a>
John M. Gabriele
Ranch Hand

Joined: Feb 18, 2001
Posts: 232
sean,
this may not be of any help since i know very little about linux,
but you can likely use the rpm package management program that comes
with rh to look at all the packages installed and remove the kaffee
(or jdk1.1) installation altogether.
there's gotta be some redhat gui program that allows you to configure
what's on your system.... ?
John M. Gabriele
Ranch Hand

Joined: Feb 18, 2001
Posts: 232
doh!!
sorry for all the duplicate posts. i was hitting submit reply
and my message wasn't coming up when i was brought back to the
thread. whoops.
Frank Carver
Sheriff

Joined: Jan 07, 1999
Posts: 6920
I've removed the duplicates. To help make sure you don't do this again:
1. Trust the Ranch. If it says your post has been added, it has. If you don't see it hit Reload or Refresh to make sure you get the lastes version of the thread.
2. Investigate your browser settings. Make sure you have your browser set to check the web site for every request. The IE defaults are particularly bad at this. Netscape users only tend to get this problem if using a caching proxy.
Ravikiran Choppalli
Ranch Hand

Joined: Nov 18, 2000
Posts: 49
I tried this one. In the SUN Java site, it was given that jdk1.2 is not compatible with Linux 7.0 (you get segmentation fault core dump), and you have to install jdk1.3. I could install it successfully.
Thanks,
Ravikiran.


Thanks,<BR>Ravikiran<BR>rkchoppalli@yahoo.com
Sanjay Bahrani
Ranch Hand

Joined: Apr 17, 2001
Posts: 38
Hi there,
It seems you had Installed JDK1.3 under Linux. I am in urgent help to install the same under Linux. If you help me in any way it will be a pleasure .
Bye.
Sanjay
Sanjay Bahrani
Ranch Hand

Joined: Apr 17, 2001
Posts: 38
Hi there,
It seems you had Installed JDK1.3 under Linux. I am in urgent help to install the same under Linux. If you help me in any way it will be a pleasure .
Bye.
Sanjay
Gregg Bolinger
GenRocket Founder
Ranch Hand

Joined: Jul 11, 2001
Posts: 15299
    
    6

You have to remove the Kaffee and there is one other JDK on there that I don't remember the name. You have to remove these before ever istalling the JDK1.3 or it won't work right. It may seem to work at first, but you will notice some bugs later one. You can use the RPM manager to remove those packages.
Again, remove before Install. Very Important!!


GenRocket - Experts at Building Test Data
Tom Graziose
Ranch Hand

Joined: Aug 24, 2000
Posts: 40
Sean,
All you have to do is add the path/To/JDK1.3 in your PATH environment variable. You can put this in the .bash_profile file. If you need more info on how to do this let me know.
Tom
Bob Petruzzelli
Greenhorn

Joined: Dec 01, 2001
Posts: 2
Originally posted by Gregg Bolinger:
You have to remove the Kaffee and there is one other JDK on there that I don't remember the name. You have to remove these before ever istalling the JDK1.3 or it won't work right. It may seem to work at first, but you will notice some bugs later one. You can use the RPM manager to remove those packages.
Again, remove before Install. Very Important!!

Gregg,
Thanks for posting. I've been experiencing segmenation faults in Red Hat Linux V 7.1 with Sun's JDK 1.3.1_01. Removing the other JDK's before re-installing Sun's JDK solved my problem.

Bob
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Jdk1.3 on linux