*
The moose likes Linux / UNIX and the fly likes Suse Linux 7.3 Pro and Windows XP Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "Suse Linux 7.3 Pro and Windows XP" Watch "Suse Linux 7.3 Pro and Windows XP" New topic
Author

Suse Linux 7.3 Pro and Windows XP

Reuben Cleetus
Ranch Hand

Joined: Jul 13, 2001
Posts: 50
Hello,
I have use a dual-boot with Suse Linux 7.3 Pro and Windows 2k. However, since I upgraded to Windows XP, I can no longer get my Linux Partition to boot.
When I tried re-installing Suse Linux 7.3, it took me through all the configuration steps, but failed when actually copying the files. The error message said something about not being able to write to the Boot Sector.
Is there something about Windows XP that prevents Suse Linux from writing to the boot sector? I don't understand it, since Suse Linux was supposed to write Lilo onto a floppy, so why would it need to write to the boot sector anyway.
I would really like to have my Linux OS back up, so any help would be greatly appreciated!
Regards,
Gregg Bolinger
GenRocket Founder
Ranch Hand

Joined: Jul 11, 2001
Posts: 15299
    
    6

When you upgraded to XP, it probably over wrote your MBR and you lost your Linux Boot Entry.
As far as re-installing, I am not sure what is happening to you. I have not used Suse, but I use Mandrake and Red Hat and have done similar re-installs and never had a problem of Linux crashing on the install.
You might try and remember the exact error message you are recieving instead of "something like...". It is hard to trouble shoot "something like..." problems.


GenRocket - Experts at Building Test Data
Guy Allard
Ranch Hand

Joined: Nov 24, 2000
Posts: 776
Hi - I agree with Gregg, we need more specific error message information.
If you install Linux to a 2nd HD, you should get a *warning* from lilo that the boot sector is not on the 1st hard disk, but is should not be a hard fail, and you should ignore it. (I run only Redhat systems).
Guy
Mathew Kuruvilla
Ranch Hand

Joined: Nov 27, 2001
Posts: 135
I don't know if XP can write protect the boot sector when it is installed. Of course, one can expect dirty tricks from M$. But If this is the case, you'll have to go into BIOS and change it back to normal. How you go into BIOS depends on your machine's BIOS. For, me, I hit F8 as soon while the machine isbooting (before the Windows ME logo is seen). You'll have to find out how to get into BIOS on XP and which key to hit for your BIOS.
If this doesn't help, consult the Linux User's Group in your area. It sounds more like a Windows problem to me
Mathew Kuruvilla
Ranch Hand

Joined: Nov 27, 2001
Posts: 135
I've been thinking a bit. You really don't need to touch the MBR to install linux.
1)You can have LILO be deposited on the boot partition (or was it the root partition?) when the installer asks you where to put LILO. That way, the installation of Linux should proceed smoothly since there won't be any attempt to overwrite the MBR.
2) Also create a floppy boot disk during the installation.
3) Boot into linux using the floppy and follow the step 4 in the link below:
http://www.enterprisedt.com/publications/dual_boot.html
Instead of using the floppy, you should be able to mount hda1 and deposit the bootsect.lnx file directly into C:\
as follows:
% mount -t msdos /dev/hda1 /mnt/dos
% cd /mnt/dos
% dd if=/dev/hda3 of=/bootsect.lnx
bs=512 count=1
NOTE: Replace hda3 with the partition where you have LILO.
% vi boot.ini
Edit BOOT.INI and add the following line at the end:
C:\BOOTSECT.LNX="Linux"
then reboot
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 15949
    
  19

Losing LILO is normal when installing a Windows OS, since they do conflict over who gets to be the bootloader. However, if you can boot into Linux from a recovery diskette or CD, you can re-run the LILO install program and make all happy again.
For details, check the LILO HOWTO and if that doesn't work do a web search.


Customer surveys are for companies who didn't pay proper attention to begin with.
Mathew Kuruvilla
Ranch Hand

Joined: Nov 27, 2001
Posts: 135
Losing LILO is not necessarily normal when you install a windows OS. Try installing any pre-winxp OS and see. I personally installed on top of Windows ME (i.e, on an existing dual boot system of RH7.1 and Windows ME). LILO still was available. I believe that win2k and win98 and win95 all work the same way. I suspect that this may have changed for win xp, since otherwise this problem would not have occurred in the first place.
Mathew
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Suse Linux 7.3 Pro and Windows XP
 
Similar Threads
How to install multiple boot menu option after installing xp
My wife on Linux
W2K & SUSE 10 / Dual boot
Passed SCJP 1.4 with 93%
XP, RH7.3, GRUB, 2 HDD's