wood burning stoves 2.0*
The moose likes Linux / UNIX and the fly likes lilo problems Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "lilo problems" Watch "lilo problems" New topic
Author

lilo problems

iemand anders
Greenhorn

Joined: Jan 11, 2003
Posts: 3
perhaps someone can help me with this problem...
my grandpa has a computer on wich he installed XP and redhat 7.2 (I dont know the settings in RH so that is the biggest problem)
he used lilo as bootloader and I dont know any of the settings..
anyhow... he decided to install redhat 8.0 over 7.2...
but what I noticed on the setup is that 8.0 normally installes GRUB as bootloader...(im not an expert at linux stuff)
it resulted into a system just saying: LI
when trying to boot...
I tried formatting the whole HD but it didnt help...
I tried fdisk /mbr but that didnt work
so I am kinda desperate and dont know what to try on his PC anymore.. because he cant boot a single OS now...
if anyone could give me idea's of what to try I would be very happy
(yea i installed xp as well and that didnt help either....)
Tnx in advance...
Ashok Mash
Ranch Hand

Joined: Oct 13, 2000
Posts: 1936
fdisk /mbr should fix it, in my opinion. I am not sure what is the problem here, but if I were you, I would try a fresh attack on the hard disk with a new (and pure) Dos boot disk with fdisk on it.
Let us know how it goes for you,
Cheers.


[ flickr ]
David O'Meara
Rancher

Joined: Mar 06, 2001
Posts: 13459

I had the same situation once, booting and getting the 'LI' prompt then nothing....
I installed win2k over the top of it and the included format fixed the problem.
I tend to agree though, can't understand why formatting the Master Boot Record didn't work
iemand anders
Greenhorn

Joined: Jan 11, 2003
Posts: 3
I tried installing DOS 6.0 and using Fdisk.. but it didnt help..
I read somewhere that its possible to have more then 1 boot records and there is a different line to format that one.. perhaps that is the problem... anyone know anythign about that?
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 15962
    
  19

When you install any version of Windows from 95 on up to XP, it overwrites the MBR. Actually, I *think* you can still choose LILO OR GRUB as boot loaders for Linux - it's just that since 7.2 or so GRUB is the default.
However, if there was a LILO installed, chances are that the GRUB got zapped and the /etc/lilo.conf is aimed at the 7.2 linux kernel which was probably erased.
Here's the fix:
1. Boot from the Red Hat install CD and select "linux rescue".
2. you should see a message saying that your old Linux has been found (we hope) and mounted at /mnt/sysimage.
3. chroot /mnt/sysimage (may be /sbin/chroot ???)
4. Now you have the proper reference points. Look in /boot for the RedHat 8 kernel name. Edit /etc/lilo.conf and replace the existing kernel name name with the Red Hat 8 kernel name and save the changes.
5. /sbin/lilo
6. Shutdown and reboot with the CD ejected. You should be able boot with LILO and enjoy life again.
Actually I understand a GRUB recovery is even easier, since the GRUB loader can understand the Linux filesystem, but you would have to have a GRUB boot diskette.


Customer surveys are for companies who didn't pay proper attention to begin with.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: lilo problems
 
Similar Threads
Redhat 7.0 with Win98
GUI in Mandrake???
dual boot uninstall
Dual Booting Linux with Win 2000
XP, RH7.3, GRUB, 2 HDD's