aspose file tools*
The moose likes Linux / UNIX and the fly likes linux firewall not able to disable Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "linux firewall not able to disable" Watch "linux firewall not able to disable" New topic
Author

linux firewall not able to disable

Maulin Vasavada
Ranch Hand

Joined: Nov 04, 2001
Posts: 1871
hi all,
i am trying to disable firewall on my Linux8.0 but i am not able to.
i go to "security level settings" and apply "No Firewall" but it doesn't work! when i go back to the same settings it says me firewall activated..
can anybody guide me? do i need to give more details? i am not a great user of linux as OS so i might be missing something obvious...
thanks
maulin
Sean Casey
Ranch Hand

Joined: Dec 16, 2000
Posts: 625
Which distribution of linux are you using?
Maulin Vasavada
Ranch Hand

Joined: Nov 04, 2001
Posts: 1871
hi
sorry. forgot to write that. i am using Red Hat 8.0
thanks
maulin
Ravee Bhat
Ranch Hand

Joined: Nov 26, 1999
Posts: 72

Looks like RHL8.0 has problems with ipchains.
for me 'ipchains -L' output is different from what firewal-config shows.
could it be problem with ipchains_save ?!!
Greg Harris
Ranch Hand

Joined: Apr 12, 2001
Posts: 1012
redhat 8.0 uses iptables... not ipchains. i am not familiar with iptables, so i reinstalled redhat 7.2 for to use ipchains and then upgraded the packages i wanted.
you might be able to turn iptables off and then install ipchains... i tried to do that, but there were some package dependancy issues that i could not resolve.


what?
shweta bohra
Greenhorn

Joined: Jul 28, 2005
Posts: 1
hello,
i'll try to solve ur prob....
u must go to rootprompt n simply flush all the iptable enabled rules..........
u can check this by......#iptables -L
THIS WILL SHOW U THE LIST OF FIREWALL RULES ENABLED....
now to turn off these..........flush all
by.......#iptables -F
n to delete any user defined chains use -x (chain name........)
that u kan conferm from first command if u find any name other than input ,output,n forward then that shld b user defined so delete it..........
now check again thru #iptables -L
U SHLD FiND........
[root@localhost root]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
[root@localhost root]#


IF U FIND LIKE THIS THAN ur firewall rules have been disabled..............

hope this'll work
good luck
Mahesh Rana
Ranch Hand

Joined: Sep 05, 2001
Posts: 139
Greg,

Isnt iptables supposed to be better than ipchains ?

Also, here are the options you have for iptables:

/etc/init.d/iptables {start|stop|restart|condrestart|status|panic|save}


SCJP2
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: linux firewall not able to disable
 
Similar Threads
not able to install wps 6.0 on windows vista home basic service pack1
Coonection to the remote host failed in ubuntu 9.10
Why Won't a Simple Socket Program Work when a Windows 7 Machine Acts as Server?
not able to install wps 6.0 on windows vista home basic service pack1
Glassfish can be accessed locally but not remotely.