I am trying to install Gnome 2.4 from source. So far I have installed glib and pkgconfig. The glib is 2.2.3. For the next step I am trying to install atk. when I run the configure of atk I get the following error checking for GLIB - version >= 2.0.0... *** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.2) *** was found! If pkg-config was correct, then it is best *** to remove the old version of GLib. You may also be able to fix the error *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing *** /etc/ld.so.conf. Make sure you have run ldconfig if that is *** required on your system. *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH *** to point to the correct configuration files no configure: error: *** GLIB 2.0.0 or better is required. The latest version of *** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed *** but not in the same location as pkg-config add the location of the file *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
I had thought when you install something it overwrites the old version... pkgconfig is finding the right version but the configure for atk is not. Anyone have any ideas here?
Jason R. Kretzer<br />Software Engineer<br />System Administrator<br /><a href="http://alia.iwarp.com" target="_blank" rel="nofollow">http://alia.iwarp.com</a>