Meaningless Drivel is fun!*
The moose likes Linux / UNIX and the fly likes odd cd-rw behavior Mandrake 10.0 official Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "odd cd-rw behavior Mandrake 10.0 official" Watch "odd cd-rw behavior Mandrake 10.0 official" New topic
Author

odd cd-rw behavior Mandrake 10.0 official

Jason Kretzer
Ranch Hand

Joined: May 31, 2001
Posts: 280
Hello list,

Installed Mdk 10.0 official.

I have the following Cd burner:

SONY CD-RW CRX160E

It appears to be mounted fine as K3B and xcdroast can both see it.
Unfortunately, both act as though there is no disc in it. Another symptom is when I am installing software from the CD's the software installer asks me to place the CD in /dev/hdc (which is the cdrom in question) when I do, it repeatedly asks me for it. A third similar symptom is when I place a CD in it that does have stuff on it and it will not read it or even place that cool automount icon on the desktop.

On a side note, this pc was upgraded from RedHat 8.0
and xcdroast worked just fine.

Here is the contents of my fstab

[root@GAMMA jason]# cat /etc/fstab
/dev/hdb2 / ext3 noatime 1 1
none /dev/pts devpts mode=0620 0 0 /dev/hdb6 /home ext3 noatime 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
/dev/hdd /mnt/cdrom2 auto
umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount
dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/windows ntfs umask=0,nls=iso8859-1,ro 0 0
none /proc proc defaults 0 0
/dev/hdb5 swap swap defaults 0 0
none /mnt/hd supermount
dev=/dev/ide/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850
0 0

I have also tried commenting out the /dev/hdc line and replacing it with

none /mnt/cdrom supermount
dev=/dev/hdc,fs=auto,ro,exec,--,user,iocharset=iso8859-1,codepage=850,umask=0
0 0

Which worked for about 20 minutes and then returned to its former behavior.

Some more information:
With the new line placed in the fstab, I get the mounted icon on the desktop. When I open it, there are no contents, even though there is a
disk in it. So, I tried to unmount and got this result.

[root@GAMMA jason]# umount /mnt/cdrom
/mnt/cdrom: not mounted

Next, I tried to mount it and got this

[root@GAMMA jason]# mount /dev/hdc /mnt/cdrom
mount: block device /dev/hdc is write-protected,
mounting read-only
mount: No medium found

Still the same disk in it, BTW.


Very odd. I appreciate any help here. If more information is required, let me know and I will provide it.

I have heard suggestions that I should switch it to being seen as a scsi device. If that would work, how would one go about that?

Thanks,

-Jason


Jason R. Kretzer<br />Software Engineer<br />System Administrator<br /><a href="http://alia.iwarp.com" target="_blank" rel="nofollow">http://alia.iwarp.com</a>
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16101
    
  21

To use cdrecord, you have to have the SCSI emulator. The author of said program labors under the delusion that CD recorders are still predominately SCSI devices and thinks Linus Torvlads is a dork for not properly appreciating the beauty that is SCSI (I'm a SCSI fan, too, but really, now!)

I was handed a drive to check out by one of the service techs yesterday to pop into my Windows box. It configured OK, but wouldn't detect discs either. Our mutual conclusion was that the drive had gone bad.

This is a common failure symptom, since the parts most likely to fail are the mechanical ones (R/W head and/or motors). The drive ID info, OTOH, is all electronic, so it doesn't really wear out.


Customer surveys are for companies who didn't pay proper attention to begin with.
Jason Kretzer
Ranch Hand

Joined: May 31, 2001
Posts: 280
OK, but how would you go about setting it up that way?

Thanks
 
GeeCON Prague 2014
 
subject: odd cd-rw behavior Mandrake 10.0 official