aspose file tools*
The moose likes Linux / UNIX and the fly likes Sound Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "Sound" Watch "Sound" New topic
Author

Sound

Mary Cole
Ranch Hand

Joined: Dec 02, 2000
Posts: 362
Hi,

Am new to lInux and I have installed Fedora3. I want to configure my sound card....is there any drivers/files I need to download ..I have creative labs sound card ..Pls guide me where I can get more info to configure
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

Haven't used red-hat alike systems for a longer time, but you often find scripts, named

sound-config
soundcard-config
snd-config

or the like.


should show you loaded modules (drivers), while


lists available drivers for the kernel.

Often, if you don't hear anything, it's just that the volume is turned down.
To fix this, test the command 'aumix' or 'kmix' for the kde-mixer.

To examine your hardware:


http://home.arcor.de/hirnstrom/bewerbung
Peter Rooke
Ranch Hand

Joined: Oct 21, 2004
Posts: 804

Also, in Fedora, try Menu [Button]-> System Settings -> Soundcard Detection
- from the resulting dialog box click the 'Play Sound' Button. You hopefully should hear a few guitar chords being played, if the system could detect your sound card.


Regards Pete
Mary Cole
Ranch Hand

Joined: Dec 02, 2000
Posts: 362
Peter , I tried that , but I couldn't hear any sound
Jiang Xiaofeng
Greenhorn

Joined: Jul 19, 2005
Posts: 25
Originally posted by Mary Cole:
Peter , I tried that , but I couldn't hear any sound



Have you tried running yum?
Peter Rooke
Ranch Hand

Joined: Oct 21, 2004
Posts: 804

Yes, I found yum to be essential for updating Linux software.

I can't tell you how to sort your sound card out using yum - I leave that to someone else with more Linux knowledge.

But, anyway yum is an update manager (from Yellow Dog - don't ask!). You will need to set it up, as I don't think it is installed with Fedora.

Once installed, you use it to automatically download packages (rpm's) and any dependant packages (which was always a pain with Linux). For example once installed and configured, you could do:


Links: YUM - and a great site for Java / J2EE / Open source packages JPackage.
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16137
    
  21

The command for Fedora is something like system-config-sound[card], but that just runs the same app the you get from the desktop menu.

First the dumb questions, since they tend to give me the most problems:

1. Are the speakers plugged into the proper jack and powered up?

2. If this is a dual-boot system, can Windows make them work?

To do in-depth diagnosis, it's useful to know the model of the soundcard, especially if it's a pre-PCI bus model. I take it this is not a motherboard with integrated sound. Hmmm. come to think of it, if you have a recend vinatge mobo with builtin sound, you'll have to make sure you're configuring the sound card and not the motherboard sound!

For a PCI-bus soundcard, you should be able to see it using the lspci utility.

To ensure the drivers loaded, the items of interest are /etc/modules.conf (or whatever it's named in FC3 - I forget) and /proc/modules. The modules.conf file is where the soundcard config (driver load) info is placed, and /proc/modules will show whether the drivers loaded OK.


Customer surveys are for companies who didn't pay proper attention to begin with.
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

Originally posted by Tim Holloway:

1. Are the speakers plugged into the proper jack and powered up?

2. If this is a dual-boot system, can Windows make them work?

3. Is the mixer raised? (kmix, aumix, ...).
Mary Cole
Ranch Hand

Joined: Dec 02, 2000
Posts: 362
1. Are the speakers plugged into the proper jack and powered up? -->>> YES

2. If this is a dual-boot system, can Windows make them work?-->> YES

3. Is the mixer raised? (kmix, aumix, ...). -->>> When I type aumix.. i get
aumix: error opening mixer
For kmix---- bash: kmix: command not found
I have inbuilt sound card on the board

egrep -i "sound|audio"
01:01.0 Multimedia audio controller: Creative Labs [SB Live! Value] EMU10k1X


am using GNOME
[ August 20, 2005: Message edited by: Mary Cole ]
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

Googling for "Creative Labs [SB Live! Value] EMU10k1X" show's there are difficulties with this chips.
The machine is a Dell?

You could do some investigations:

Which distro do you use? SuSe, Fedore, Ubuntu, ...?
Perhaps they have a forum, where you may get more help.

I'm not sound-expert.
Also note: There are two different sound-systems: ALSA and OSS.
Depending on your chipset, the one or the other works better, and if it's working with both, alsa is preferred today, but sometimes OSS would work, while alsa wouldn't.
And depending on your distribution, one of them might be setup.
Changing to the other system might be some work.
Mary Cole
Ranch Hand

Joined: Dec 02, 2000
Posts: 362
[root@localhost ~]# lsmod | grep snd-emu10k1x
[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.12-1.1372_FC3 #1 Fri Jul 15 00:59:10 EDT 2005 i686 i686 i386 GNU/Linux
[root@localhost ~]# dmesg | grep emu10
[root@localhost ~]# lsmod | grep snd-emu10k1

THis is the info I got
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

[root@localhost ~]# lsmod | grep snd-emu10k1x
[root@localhost ~]# lsmod | grep snd-emu10k1

That means the module (driver) isn't loaded.

[root@localhost ~]# dmesg | grep emu10

And that it isn't not loaded because of some error - there was no attempt to load it.

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.12-1.1372_FC3 #1 Fri Jul 15 00:59:10 EDT 2005 i686 i686 i386 GNU/Linux

That's a very recent kernel.

I got another command, to see whether the module is present at all:


If 'snd-emu10k1x' is shown, you may try to load it with:
Mary Cole
Ranch Hand

Joined: Dec 02, 2000
Posts: 362
[root@localhost ~]# modprobe -l|grep snd-emu10k1
/lib/modules/2.6.12-1.1372_FC3/kernel/sound/pci/emu10k1/snd-emu10k1-synth.ko
/lib/modules/2.6.12-1.1372_FC3/kernel/sound/pci/emu10k1/snd-emu10k1x.ko
/lib/modules/2.6.12-1.1372_FC3/kernel/sound/pci/emu10k1/snd-emu10k1.ko


[root@localhost ~]# modprobe snd-emu10k1x
[root@localhost ~]# modprobe -l|grep snd-emu10k1
/lib/modules/2.6.12-1.1372_FC3/kernel/sound/pci/emu10k1/snd-emu10k1-synth.ko
/lib/modules/2.6.12-1.1372_FC3/kernel/sound/pci/emu10k1/snd-emu10k1x.ko
/lib/modules/2.6.12-1.1372_FC3/kernel/sound/pci/emu10k1/snd-emu10k1.ko
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923


That's good news, so the module is loaded right now (but has to be reloaded after shutdown).

And do you here something now, when playing sound, enabling system-sounds, etc.?

Then we need a FC-user, to tell us, where to make the module-loading persistent, probably in /etc/modutils/alsa-base, but how exactly?
Mary Cole
Ranch Hand

Joined: Dec 02, 2000
Posts: 362
Stefan,
Still am not able to hear the sound :roll:
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16137
    
  21

Originally posted by Stefan Wagner:

Then we need a FC-user, to tell us, where to make the module-loading persistent, probably in /etc/modutils/alsa-base, but how exactly?


It's all done in the modules.conf file. I don't have a sample handly just now, though.
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

She is still not hearing the sound:
Mary Cole
Ranch Hand

Joined: Dec 02, 2000
Posts: 362
Any luck?
Bharat Ruparel
Ranch Hand

Joined: Jul 30, 2003
Posts: 493
Hello Mary,
I am no Linux expert, but a friend helped me install RedHat Fedora Core 4 on my Dell Latitude 610 laptop. Initially, we could not get the sound to work either. I did a search on Google as follows:

Red Hat Fedora Sound Dell Latitude

and found the following link which helped resolve the problem.

http://forums.us.dell.com/supportforums/board/message?board.id=latit_audio&message.id=6882

Basically, all I had to do was to enable the "External Amplifier"

To do that under Gnome:

1. Go to the Applications menu
2. Go to the Sound & Video sub menu
3. Pick Volume Control sub menu option
4. Select Switches Tab
5. Click on the External Amplifier check box to enable it
6. Save and reboot Linux

If you had the same problem/configuration that I have, you should be all set.

Hope this helps.

Regards,

Bharat


SCJP,SCJD,SCWCD,SCBCD,SCDJWS,SCEA
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Sound