aspose file tools*
The moose likes Linux / UNIX and the fly likes Eclipse on Debian Sarge Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "Eclipse on Debian Sarge" Watch "Eclipse on Debian Sarge" New topic
Author

Eclipse on Debian Sarge

benny rusli
Ranch Hand

Joined: Jan 15, 2005
Posts: 72
Hello people,

i have the following problem during the invocation of Eclipse 3.1 under Debian Sarge Linux. The error occured while i am running eclipse from command line console : ./eclipse and then the error is : "An error has occurred. See the log file /opt/eclipse/configuration/11223423434.log."
And here is the log file :



I tried with the following command from console but without success :
./eclipse -Dosgi.locking=none

Can someone please help me to solve the wried problem ? i appreciate any help, thanks.
benny rusli
Ranch Hand

Joined: Jan 15, 2005
Posts: 72
Hello people,

the problem before is not solved, and i try to call the eclipse with the following command from console :



After that, an error has occured, See the log file /root/workspace/.metadata/.log

Here is the log file :



i think, i should set library swt with the "export LD_LIBRARY_PATH=/pathtolibrary" command, but where is the swt library placed ?

And then i try, to use "which java" in console and the output is /usr/bin/java. And try to call the eclipse with following command but without success.



Any help will be appreciated.
Layne Lund
Ranch Hand

Joined: Dec 06, 2001
Posts: 3061
I'm not exactly sure how to solve your problem. To find where a file is located, such as the library mentioned in the log file, you should use the locate command. If it isn't installed, then you should install it

Layne


Java API Documentation
The Java Tutorial
Nawar Gailani
Ranch Hand

Joined: Feb 08, 2005
Posts: 46
Hi arifin rusli,
Why you don't try Sun JDK? If I understood right, you are using Kaffe.
Also did you install eclipse from Debian?
I have two Debian based distrobutions, and what i did is downloading the JDK from sun and following this:
http://wiki.serios.net/wiki/Debian_Java_JRE/JDK_installation_with_java-package
For eclipse, i just downloaded it from the eclipse website and extracted it. No installation for eclipse is required, but you should set JAVA_HOME in /etc/bash.bashrc

Hope that helps
benny rusli
Ranch Hand

Joined: Jan 15, 2005
Posts: 72
Hello people,

how to uninstall the kaffe JDK compeletly inclusive the sym link ? i tried to use jdk from sun, but i am not getting the output from "java -version". What should i do ? set the JAVA_HOME ? how to erase the old JAVA_HOME path from environment setting under Debian Sarge ? where is the configuration file from the environment setting under Debian Sarge (i have taken a look in /etc/profile but there was not there) ? Thanks for responding my question.
Nawar Gailani
Ranch Hand

Joined: Feb 08, 2005
Posts: 46
arifin,
I suppose you followed the instructions in the link I wrote.
For Kaffe, I don't have it by default, I have Kanotix which is Debian based distribution and it came with Sun JRE 1.4, anyway, if you installed jdk 1.5 or 1.4 as in the instructions in the link, you can execute (as root):
# update-alternatives --config java
and
# update-alternatives --config javac
As I remember you can choose a number represent which java or javac, then see what java -version says.
For uninstalling, in the link says:
If you wish to remove some of the JRE/JDKs you have installed, execute (example: for Sun JRE 1.4.2):

# apt-get remove sun-j2re1.4
It is not that complicated really, if you just follow the instructions, everything should work for you.
As for how to set JAVA_HOME variable I didn't need to set it for eclipse or Netbeans, but as i remember IntelliJ require it and i opened /etc/bash.bashrc (this is a file in /etc directory) and i append to the end these two lines:
JAVA_HOME="/usr/lib/j2sdk1.5-sun"
export JAVA_HOME
Maybe there is a better way to do it, but it worked for me.
benny rusli
Ranch Hand

Joined: Jan 15, 2005
Posts: 72
Hello people,

to set java home to environment setting for temporarly, i use this command :

JAVA_HOME=/usr/lib/java
export JAVA_HOME

PATH=$JAVA_HOME/bin:$PATH
export PATH

with java -version, the output shows the jdk version, but if i close the console, then open a new console and type java -version, there is not output. Can someone tell me how to set JAVA_HOME in configuration file ? where is the configuration file in Debian Sarge ? in /etc, but where ? any help would be appreciated.
[ January 27, 2006: Message edited by: arifin rusli ]
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

/etc/profile or /etc/bash.bashrc for systemwide setting.
~/.bashrc for a single user.


http://home.arcor.de/hirnstrom/bewerbung
benny rusli
Ranch Hand

Joined: Jan 15, 2005
Posts: 72
Hello people,

thanks for responding my question. I have tried to put the JAVA_HOME and PATH in bash.bashrc and then restarting the system but the result is the same, i cann't execute the java program from console. Here is my profile and bash.bashrc from /etc folder under Debian Sarge. Can someone tell me how to put to approriate place, as you can see i put it in the end of bash.bashrc, is that right ? but without success.





Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

@arifin: can you please edit your initial post?
Break the very long lines into two or three, which are between code-tags.
I only have a 1400x1050 Display and it's hard to read here with the text jumping from left to right.

Thanks.
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

You may use
to check whether your modifications had success.

Which error do you get now?
Nawar Gailani
Ranch Hand

Joined: Feb 08, 2005
Posts: 46
arifin,
I also agree with Stefan about your first posts. It is annoying to scroll
right and going back left all the time, don't you agree?
About the JAVA_HOME, why you don't try JAVA_HOME="/usr/lib/java" instead of
JAVA_HOME=/usr/lib/java ?
benny rusli
Ranch Hand

Joined: Jan 15, 2005
Posts: 72
Hello people,

thanks for responding my question. The problem is solved if i put the JAVA_HOME and PATH in /root/.bashrc. Thanks Stefan for the information, next time i will split the code into two or three part. Besides that, after remove the kaffa jdk and installing the sun jdk, i got the eclipse running perfectly. The only thing i dont get right is put the JAVA_HOME and PATH into /etc/bash.bashrc or /etc/profile and get the system wide javahome setting. There is no error, if i write java -version, there output said the command java is not found. Another question : which ist better, the Eclipse IDE or Netbeans IDE, i have tested the both, from the speed execution, Eclipse is speeder than Netbeans, which Swing and AWT Builder for the Eclipse are you use ? i use Jigloo GUI Builder for Eclipse but dont satisfiy with that. Many thanks.
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

You don't have to split the code into multiple parts -
just the very long lines.

If you use code-tags, the code isn't automatically broken
into separate lines, because this might lead
to a different meaning.

In the edit-window, you don't need to insert linefeeds by default,
if the text isn't put between code-tags.
The lines are broken automatically.

But if there are very long lines of code on a page,
the whole page is laid out to the maximum width reached so far.

For a new question, you should use a new topic.
Especially, as long as this thread isn't readable.

The icon with paper and pencil allows to edit a posting.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse on Debian Sarge