File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Linux / UNIX and the fly likes /etc/.java/versions missing Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "/etc/.java/versions missing" Watch "/etc/.java/versions missing" New topic
Author

/etc/.java/versions missing

Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

Firefox shows in the 'about:config' page an entry to:

but it is missing on my machine.
The directory exists with a subdirectory .systemPrefs in it, which contains two empty files.
Does anybody know what should be there?
The search on java.sun.com leads to 0 results for /etc/.java/versions - google not much better.


http://home.arcor.de/hirnstrom/bewerbung
Joe Ess
Bartender

Joined: Oct 29, 2001
Posts: 8836
    
    7

I checked my setup (Gentoo Linux, Firefox 1.0.6, JDK 1.4.2_10) and I don't have that setting in my Firefox config files or that directory in /etc.


"blabbing like a narcissistic fool with a superiority complex" ~ N.A.
[How To Ask Questions On JavaRanch]
Balaji Loganathan
author and deputy
Bartender

Joined: Jul 13, 2001
Posts: 3150
[UBUNTU Linux, FireFox]
Actually I can see the directory /etc/.java but not the file or folder "versions"

What are you trying to do with that ??


Spritle Software Blogs
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

I have no idea where they come from, nor what their intentional use is - perhaps they come from the default java-installation which is gcj.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: /etc/.java/versions missing
 
Similar Threads
To Show Errors in Eclipse.
Should Java 7/8 be backwards compatible?
"Gaps" in Sun's (Java 1.5) JCE vs. Bouncy Castle 1.41
Error occurs when creating WSDL file
I cant seem to fix this compile error !! please help me