File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Linux / UNIX and the fly likes IRIX JRE 1.5? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "IRIX JRE 1.5?" Watch "IRIX JRE 1.5?" New topic
Author

IRIX JRE 1.5?

Scott Cook
Greenhorn

Joined: Aug 01, 2006
Posts: 14
Does anyone know where I can find JRE 1.5 for IRIX?

I've looked at:
http://java.com/en/download/manual.jsp
(IRIX is not mentioned)

and:
http://www.sgi.com/products/evaluation/
(which only has v1.4.1_06)

Typing "versions" on our SGI machine shows:
Java2 v1.4.1_03 Execution Environment (Sun JRE v1.4.1_03)

Does this mean that a SUN JRE works on SGI? Then, all I need to do is install the Solaris JRE on the SGI.

Kavya Krushi on post:
http://www.coderanch.com/t/387809/java/java/Java-SGI
writes:
The JDK Linux version should work for Irix too ... Check the Sun Site ...

I didn't see any mention of the Linux version working on an SGI when I checked the Sun Site.

I have code using 1.5 features (generics, enhanced for loops, etc.), and would really like to avoid re-writing to 1.4 standards. (IRIX is a major operating system for our company)

Any info/insight would be greatly appreciated!
Scott
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

I can't tell you whether it will work on IRIX/SGI, but can't you just try?


http://home.arcor.de/hirnstrom/bewerbung
Scott Cook
Greenhorn

Joined: Aug 01, 2006
Posts: 14
Stefan,
Yes, I've tried installing the LINUX and SUN versions(after I posted the question).

Linux(self-extracting file) and Linux AMD 64 give the message:
Do you agree to the above license terms? [yes or no]
y
Unpacking...
Checksumming...
1
The download file appears to be corrupted.

Solaris(32-bit),Solaris(64-bit) give the message:
Do you agree to the above license terms? [yes or no]
y
Unpacking...
Checksumming...
0
0
Extracting...
./jre-1_5_0_08-solaris-sparcv9.sh: ./install.sfx.455504: cannot execute


The version of IRIX I'm using is:
>uname -a
IRIX64 gin 6.5 01080747 IP35

Unless anyone else has any ideas, I'll start making my code 1.4 compliant.
Thanks!
Scott
[ August 22, 2006: Message edited by: Scott Cook ]
Henrik �stman
Greenhorn

Joined: Apr 09, 2005
Posts: 11
Eh?

Solaris is available for x86 and Sparc processors and thus two versions of JVM are available, one for x86 and one for sparc.

The system you have probably has MIPS processors and SUN has not released any JVM for this architecture that i know. The Java version bundled with IRIX is probably a SGI lincensed port of Java.

Newer SGI machines have the Intel Itanium processors, but they are not supported my Sun either. Maby intel has a port?

Maybe GNU Java is better supported?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: IRIX JRE 1.5?