aspose file tools*
The moose likes Linux / UNIX and the fly likes yum installed question Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "yum installed question" Watch "yum installed question" New topic
Author

yum installed question

Joe Harry
Ranch Hand

Joined: Sep 26, 2006
Posts: 9243
    
    1

Guys,

I tried installing RealPlayer10GOLD through yum installer. But first I followed some tutorial where they delete the existing yum.conf and reinstall yum. Here is what I did at the terminal and chahging the directory to etc,

mv -f yum.conf yum.conf.bak

rpm -Uvh /root/yum /root/livna-release-5.rpm

After this, it says livna-release-5-8 and yum is installed. But later when I tried yum list available, it gave me "No such config file /etc/yum.conf"

WHY? Just because of this, I reinstalled Fedora.



SCJP 1.4, SCWCD 1.4 - Hints for you, SCBCD Hints - Demnachst, SCDJWS - Auch Demnachst
Did a rm -R / to find out that I lost my entire Linux installation!
Chad Clites
Ranch Hand

Joined: Aug 16, 2005
Posts: 134
You renamed your yum file, and then didn't create a new one. None of the instructions I have seen anywhere say anything about renaming the yum.config. Perhaps the instructions said to copy the config file? The livna-release doesn't contain a new yum.conf.

Next time, you can just do mv -f yum.conf.bak yum.conf, which would rename your config file back to what it was.

EDIT: I realize this is a few days old...
[ June 27, 2007: Message edited by: Chad Clites ]
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: yum installed question
 
Similar Threads
problem installing Mplayer
easier way to manage packages?
updating svn to new version
Configuring newly installed gcc 3.4.3
Installing Flash in Firefox for Red Hat Linux Enterprise 4