aspose file tools*
The moose likes Linux / UNIX and the fly likes [rpm] doesn't find existing dependecy package Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "[rpm] doesn Watch "[rpm] doesn New topic
Author

[rpm] doesn't find existing dependecy package

Alessandro Ilardo
Ranch Hand

Joined: Dec 23, 2005
Posts: 218
Hi there,
I'm using Suse 10.2 and I'm trying to install this package
pptpconfig-20060821-1suse.noarch.rpm

It keeps asking me dependencies which already are in system, but aparently cannot find.

Dependencied installed:

/usr/lib/php-pcntl/lib
/usr/lib/php-pcntl/lib/php
/usr/lib/php-pcntl/lib/php/extensions
/usr/lib/php-pcntl/lib/php/extensions/no-debug-non-zts-20020429
/usr/lib/php-pcntl/lib/php/extensions/no-debug-non-zts-20020429/php_gtk.so
/usr/share/doc/php-gtk-pcntl-1.0.2
/usr/share/doc/php-gtk-pcntl-1.0.2/AUTHORS
/usr/share/doc/php-gtk-pcntl-1.0.2/COPYING.LIB
/usr/share/doc/php-gtk-pcntl-1.0.2/ChangeLog
/usr/share/doc/php-gtk-pcntl-1.0.2/NEWS
/usr/share/doc/php-gtk-pcntl-1.0.2/README
/usr/share/doc/php-gtk-pcntl-1.0.2/TODO



/bin/php-pcntl
/usr/lib/php-pcntl
/usr/lib/php-pcntl/bin
/usr/lib/php-pcntl/bin/php
/usr/share/doc/php-pcntl-4.4.0
/usr/share/doc/php-pcntl-4.4.0/CODING_STANDARDS
/usr/share/doc/php-pcntl-4.4.0/CREDITS
/usr/share/doc/php-pcntl-4.4.0/EXTENSIONS
/usr/share/doc/php-pcntl-4.4.0/INSTALL
/usr/share/doc/php-pcntl-4.4.0/LICENSE
/usr/share/doc/php-pcntl-4.4.0/NEWS
/usr/share/doc/php-pcntl-4.4.0/README.CVS-RULES
/usr/share/doc/php-pcntl-4.4.0/README.EXTENSIONS
/usr/share/doc/php-pcntl-4.4.0/README.EXT_SKEL
/usr/share/doc/php-pcntl-4.4.0/README.PARAMETER_PARSING_API
/usr/share/doc/php-pcntl-4.4.0/README.QNX
/usr/share/doc/php-pcntl-4.4.0/README.SELF-CONTAINED-EXTENSIONS
/usr/share/doc/php-pcntl-4.4.0/README.STREAMS
/usr/share/doc/php-pcntl-4.4.0/README.SUBMITTING_PATCH
/usr/share/doc/php-pcntl-4.4.0/README.TESTING
/usr/share/doc/php-pcntl-4.4.0/README.UNIX-BUILD-SYSTEM
/usr/share/doc/php-pcntl-4.4.0/README.Zeus
/usr/share/doc/php-pcntl-4.4.0/TSRM_LICENSE
/usr/share/doc/php-pcntl-4.4.0/ZEND_CHANGES
/usr/share/doc/php-pcntl-4.4.0/ZEND_LICENSE
/usr/share/doc/php-pcntl-4.4.0/regex_COPYRIGHT
/usr/share/man/man1/php-pcntl.1.gz


And when I try to install it using the command line I get

rpm --install pptpconfig-20060821-1suse.noarch.rpm
warning: pptpconfig-20060821-1suse.noarch.rpm: Header V3 DSA signature: NOKEY, key ID 862acc42
error: Failed dependencies:
/bin/php4-pcntl is needed by pptpconfig-20060821-1suse.noarch
php4-pcntl >= 4.3.9-2 is needed by pptpconfig-20060821-1suse.noarch
php4-pcntl-gtk is needed by pptpconfig-20060821-1suse.noarch


How do I specify where the dependencies are?
Thanks in advance


trying to decode a woman mind....
Ernest Friedman-Hill
author and iconoclast
Marshal

Joined: Jul 08, 2003
Posts: 24187
    
  34

I'm not familiar with these specific packages, but I'm not sure you do have the prerequisites. For example, RPM wants /bin/php4-pcntl, you have /bin/php-pcntl. The "4" suggests that these are two separate programs. If you say

rpm -q | grep php

what do you see? Do you see packages php4-pcntl and php4-pcntl-gtk, with adequate version numbers? You may need to seek these out and install them.


[Jess in Action][AskingGoodQuestions]
Alessandro Ilardo
Ranch Hand

Joined: Dec 23, 2005
Posts: 218
I'm trying to install the pptp client configuration tool.

This is the out put
php-pcntl-4.4.0-1
apache2-mod_php5-5.1.2-29.25.3
php5-5.1.2-29.25.3
php5-mysql-5.1.2-29.25.3
php-gtk-pcntl-1.0.2-1
php5-mysqli-5.1.2-29.25.3
Ernest Friedman-Hill
author and iconoclast
Marshal

Joined: Jul 08, 2003
Posts: 24187
    
  34

So, you need the packages php4-pcntl and php4-pcntl-gtk, which you don't have. Alternately, maybe there's a newer version of pptpconfig which uses the php5 packages you already have.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: [rpm] doesn't find existing dependecy package