This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes Linux / UNIX and the fly likes Unable to run Applets Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "Unable to run Applets" Watch "Unable to run Applets" New topic
Author

Unable to run Applets

Hussein Baghdadi
clojure forum advocate
Bartender

Joined: Nov 08, 2003
Posts: 3479

Hey,
Recently, I installed a fresh installation of Ubuntu 8.04 on my laptop.
JDK 1.6.06 is installed via Synaptic.
Then, I run this command:
sudo update-java-alternatives --set java-6-sun
But I'm unable to run Java applets in FireFox 3.0.3
Any ideas?
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41599
    
  55
What does "unable to run" mean? Are there any messages in the Java Console?

Is Java turned in the browser?

Can you run applets using appletviewer?


Ping & DNS - my free Android networking tools app
Hussein Baghdadi
clojure forum advocate
Bartender

Joined: Nov 08, 2003
Posts: 3479

Well, it seems that there is a package called sun-java6-plugin should be installed in addition to sun-java6-jdk , sun-java6-jre , sun-java6-bin and the list go on ...
Why JDK6 is partitioned to many packages in Ubuntu repositories?
How I'm supposed to remember all these packages? why not one package?

Any way, thank you Ulf
Jesper de Jong
Java Cowboy
Saloon Keeper

Joined: Aug 16, 2005
Posts: 14114
    
  16

So, does it work now?

Note that if you're running the 64-bit version of Ubuntu, it's not going to work, because Sun still doesn't have a 64-bit version of the Java plug-in. As far as I know, this is going to come "soon" (I think with Java 6 update 10).


Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 7 API documentation
Scala Notes - My blog about Scala
Hussein Baghdadi
clojure forum advocate
Bartender

Joined: Nov 08, 2003
Posts: 3479

Yes it works.
I'm running 32-bit version of Ubuntu 8.04
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16019
    
  20

There is, thank goodness! a way to run applets on 64-bit Linux. I found a web site that gave a simple way to hack it in. I forgt its URL though.

No luck with Flash, however. I'm still Flash-blind. Which considering how Flash is abused is sometimes just a well.

It will be nice to have native applet support for 64-bit, however.


Customer surveys are for companies who didn't pay proper attention to begin with.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5823
    
    7

Here is another possibility. Do not use the Firefox that comes with your 64-bit Linux distro. Instead, download Firefox from the Mozilla web site - as far as I can tell they are all 32-bit versions - and install that, which involves simply unpacking the tar.gz file. I placed mine at /opt/firefox.

Next, download a 32-bit JDK (or JRE) from the Sun web site, and install it, which involves running the .bin file (for Ubunutu, do not download the *.rpm.bin version, get the other one). I placed mine at /usr/java/32bit/jdk1.6.0_07. Then follow the instructions to manually install the Java applets plugin..

Start (or restart) Firefox, and applets should now work. I did this on Kubuntu 8.04 64-bit and it works for me.


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Unable to run Applets