File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Mac OS and the fly likes Eclipse v3.0 M4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Mac OS
Bookmark "Eclipse v3.0 M4" Watch "Eclipse v3.0 M4" New topic
Author

Eclipse v3.0 M4

Michael Yuan
author
Ranch Hand

Joined: Mar 07, 2002
Posts: 1427
does anyone has problem with Eclipse v3.0 M4 on OS X 10.2.8 (yes, I know I should upgrade ...)? I cannot open any Java file in the editor. It just pops up a box saying "editor cannot be initialized". All my java source files are in in directories linked from the workspace -- if that matters.
Any suggestion will be greated appreciated!


Seam Framework: http://www.amazon.com/exec/obidos/ASIN/0137129394/mobileenterpr-20/
Ringful: http://www.ringful.com/
Nathan Pitts
Greenhorn

Joined: Oct 15, 2002
Posts: 1
I am using the exact same setup and have no problems editing java files...The only thing I have noticed that seems buggy with M4 on OSX 10.2.8 is that sometimes when closing eclipse, the jvm crashes. It doesn't seem to affect my projects, so I haven't worried too much about it....
-nathan
Michael Yuan
author
Ranch Hand

Joined: Mar 07, 2002
Posts: 1427
OK, it must be something I did then. I think I will do a clean install of Eclipse after I upgrade to Panther. IntelliJ is my main IDE now but I wish to try out Eclipse.
jeroen dijkmeijer
Ranch Hand

Joined: Sep 26, 2003
Posts: 131
Here is my opinion (eclipse 2.1.1 on winnt): I had the same thing after a eclipse was not shutdown nicely.
I had to remove all the contents from the eclipse install directory, (eclipse starts up again, with the message finalizing install), after that after adding the projects I had to change the jdk setting in the libraries, on java build path, in project properties.
Michael Yuan
author
Ranch Hand

Joined: Mar 07, 2002
Posts: 1427
Just a quick update: I never get M4 to work on either my Mac box or my windows xp box. Same error: cannot initialize the Java editor -- the plain text editor worked fine. I guess my project might be peculiar!
So, I switched back to M3 and it worked great.
Maarten Meijer
Greenhorn

Joined: Nov 18, 2003
Posts: 2
No problems with running Eclipse M4 on my iMac with 10.2.8.
Another thing is, I cannot get the Tomcat plug in from www.sysdeo.com to work!
It shows up OK, but it refuses to update my server.xml file
Any help?
Maarten
[ November 18, 2003: Message edited by: Maarten Meijer ]

Fast Online Lighting Design
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse v3.0 M4