aspose file tools*
The moose likes Mac OS and the fly likes L&F error when starting application Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Mac OS
Bookmark "L&F error when starting application" Watch "L&F error when starting application" New topic
Author

L&F error when starting application

Richard Everhart
Ranch Hand

Joined: Nov 19, 2003
Posts: 54
I'm trying to execute a Java application I'm developing on Mac OS 10.3.5. But I keep getting this error:



I've installed the recent Java update to 1.4.2_05 so I'm wondering if that has anything to do with it. I honestly can't say if it does since this is the first time that I've run the application outside of NetBeans 3.6, which I'm using for development. Also, you may have noticed that I'm using ant to execute the appliction.

So, I'm stumped as to what is causing the Java to be unable to find the Aqua look and feel. Anyone have any suggestions?

Thanks.

Rich
Warren Dew
blacksmith
Ranch Hand

Joined: Mar 04, 2004
Posts: 1332
    
    2
My first guess would be that it's some kind of class path issue, but I don't really know. I've had no problems with 1.4.2. I'm on 10.2.8 rather than Jaguar, but I guess I'd be surprised if that made a difference.

Do other Swing applications run properly?
Simon Brown
sharp shooter, and author
Ranch Hand

Joined: May 10, 2000
Posts: 1913
    
    6
Are you explicitly setting the LAF? I'm also using the updated 1.4.2_05 and have no problems running a Swing app that I'm working on. BTW, the first line in my app is:

 
It is sorta covered in the JavaRanch Style Guide.
 
subject: L&F error when starting application